[Bug] Import All only imports single at a time

Can’t believe this is still a thing but, I’ve to import 100+ meshes to a scene, Hitting the Import All button, requires you to hit it each time per mesh. This isn’t an Import all button is it? :stuck_out_tongue:

Hitting Import All 100+ times gets pretty tiring, don’t you think? :slight_smile:

1 Like

Hi Sythen -

I have attempted to reproduce this issue internally and am able to import All for 100 Static Meshes with only hitting the Import All button once. I tried also adding in Morph Targets and Skeletal Meshes to make more than 100 files and only when the Import hit a different file type did I get another pop up. Can you provide anymore information as to the type of project (have you tested it in a Blank Project) and what type of assets you are importing.

Thank You

Eric Ketchum

I have the same issues with my FBX files which are identical except the animation take in them.
They contain a Mesh with morph targets A skeleton and an animation take.

Hi gidcheen and Sythen -

What are the first import settings that you choose when you import your assets before first hitting Import All?

Thank You

Eric Ketchum

All I’ve done is literally export a few meshes from 3Ds as FBX to the content folder and let Auto Directory in UE4 auto import the files. On the first mesh turn off generate lightmaps (I want to use my own) and hit import all, It then requires me to do it on a per asset basis.

Hi Sythen -

Thank you for the additional information. I have been able to replicate this issue and have reported the bug as UE-19201. As we investigate a solution, I will keep you informed here.

Eric Ketchum

this is still an issue and has never been fixed - i have never been able to import all EVER - I have 23+ projects on 3 different computers with hundreds of models and jsut now for some reason my proect wouldnt open - I had to move some stuff out of directories then move back to get open - when it opened it had to re-import a hundred plus models and - absolutely the import all does not work- I never change anything just import select files - import all - never never never has it ever worked for the past 2 years

UE 4.27 and the import all button still don’t work :sob:

Can confirm that it does not work on 4.27.2

For anyone finding this in the future.
This bug does not appear when you drag-and-drop into the editor directly.
It does appear when you drop files into the File Explorer, then press Unreal Engine import notification notification.

How is this still a bug after 7 years? For the love of all that is holy, fix this already Epic, wtf?

STILL an issue in 5.1 - is this just never going to be addressed?

Current version of 5.3, and over eight years since this was reported and it is still happening. Can someone actually fix this?

Yep… this still happens in 5.3

What the hell…

lol bruh

Still happening. Really annoying when you have 100+ meshes to import and each one takes over a minute. I’d prefer not to sit here for an hour clicking Import All for each file.