[BUG] If i create a default FPS BP project and put in a trigger volume or trigger box, the projectile balls bounce off of it no matter what

If i create a default FPS BP project and put in a trigger volume or trigger box and when i shoot, the projectile balls bounce off of them no matter what. Its a collision bug, please fix. Thanks :slight_smile:

I can confirm that there seems to be something odd about how this is handled on 4.9 and 4.10 preview 3 when using blueprints.

I checked that projectile BP is set to fire only on “Event Hit” and not on “Event Begin Overlap”. Also made sure that Trigger Volume doesn’t have tick on “Generate Hit Events”.

my findings so far:

  1. when I create BP FPS template on 4.7 and place trigger volume, I can shoot through the volume without hit event triggering, this is what I’d expect.

  2. when I create BP FPS template on 4.9 and 4.10 preview3 and place trigger volume, projectile bounces back from trigger volume, even it shouldn’t.

  3. when I create c++ FPS template on 4.9 and place trigger volume, it works as expected. I did notice that c++ template adds custom projectile collision channel (BP version didn’t). But even if I change projectile component to use same collision settings as BP template, it still works as expected.

Only way to stop the collision with the trigger box, I found, was to set the, “collision enabled,” on the trigger volume to “no collision.” All other settings, including, “Query only (no physics collsion,)” resulted in physical collisions, even if all of the trigger box channels were set to ignore.

Hello everyone,

I have been able to reproduce this issue, and have entered a bug report, UE-22845. Thank you for your reports, and for providing a workaround.

Have a great day,

Sean Flint

Can we track that issue somehow ?

Thanks guys!

We do have plans for a bug-tracking system, but there is no timeline for when that will be ready at this time. As of right now, I will be able to provide updates as they become available.

Alright, thanks and do please update the issue, i am stuck on a project that im doing and i need that fix so i can continue.

For right now, the workarounds that have been posted above should be fine to use, and should allow you to continue work with your project.

That disables the actual trigger tho, so nothing will happen if i coded it.

Here is another way to get the projectile collision to function properly.

What you need to do is create a custom Object Channel for your projectile. To do this, go to Edit->Project Settings->Collision. Then, under the Object Channels tab, click New Object Channel and call it whatever you’d like your projectile to be called (I used Bullet).

Once you have this Object Channel set up, go into your Projectile blueprint and select the Collision Component. Under the Collision tab in the details panel, set the Collision Presets to Custom, and use the Object Type dropdown to select your newly-created Object Channel.

Finally, go into the trigger volume’s collision settings, and ensure that it is set to overlap whatever your new Object Channel is. This should allow the projectile to pass through the volume.

Thank You!

I’m new at this, but I found a solution:

Click on your Trigger Volume.
In the Details panel, find ‘>Collision’. (it’s below physics)
Click on ‘Collision Presets’ > and select Trigger

The default is “OverlapAllDynamic”

By setting to Trigger, you can walk into the trigger, and it will detect the payer, and you can shoot your gun without it bouncing off an invisible object.