[Bug] Gamified Basics Tutorial won't advance past 15th step

[Bug] Gamified Basics Tutorial won’t advance past 15th step (where you drop in SM_WalkWay_1)

Rocket Version: Beta 1940051
InstallPath: C:\Program Files\RocketBeta
Specs: See attached DxDiag dump

After completing the step where you drop in the SM_WalkWay_1 the tutorial won’t advance anymore, the next button is grayed out. The tutorial even stays stuck if you position the walk way correctly and let the character run across it.
alt text

I tried that tutorial. No problems for me. Although i needed to manually type in the location X=210, Y=420, Z=570 into the location of SM_Walkway_1 in details tab. After applying those values the Next button was enabled. I then collected the coin and went to Room Two.

Hi Patrick,

Thank you for your report. Could you please try Satheesh’s suggestion of manually inputting the location and let us know if that has made a difference for you? If not I will be happy to further assist you.



  • Rocket Version: 1940051

  • Install Path: C:\Program Files\Rocket

  • OS: Windows 7 (64bit/Ultimate)

  • RAM: 32 GB

  • Graphics Card: GTX 780M w/ 4 GB

  • UAC: On

Reproduced 1/3 at same step in the tutorial. Manually inputting values X=210, Y=420, Z=570 didnt enable the next button, however rebooting Rocket and trying again worked.

Hi Johnathan,

Thank you for this additional information. I will investigate this with the documentation team and create a report if needed. Please let us know if there is anything else behaving unexpectedly.



It appears to be working now, perhaps I needed a reboot.

The screen I got stuck on was the one shown below (sorry I didn’t realize the image failed to upload entirely last time). The tutorial was not advancing when I would drop in SM_Walkway_1, so I had never been able to reach the screen that showed the transform coords to enter, so I just eyeballed it, and not very accurately at that.

I had even tried restarting the editor a few times… anyway right now it’s a non repro.