BUG: Gamepad controls editor menus during Mobile PIE session

As a follow up to the original thread, I was instructed to re-post this as a bug.

During a Mobile PIE session, your gamepad will be annoyingly controlling the Editor’s menus simultaneously while you are attempting to control your game. This happens especially if your “Standalone Window Size” settings are smaller than your monitor’s native resolution. During a regular New Editor Window PIE session (non-mobile), this issue usually does not occur. I would propose that all Editor menu control should be disabled for gamepad input.

Thank you very much for your time and consideration.


Original thread here: https://answers.unrealengine.com/questions/522018/how-to-stop-gamepad-from-controlling-editor-menus.html

Awesome! Thank you, , for looking into that and logging a report of the issue.

Have a great day.



Thank you for submitting a bug report. I have reproduced this issue and logged a report for it here

You can track the report’s status as the issue is reviewed by our development staff. Please be aware that this issue may not be prioritized or fixed soon.


2019 and still unresolved. Says Backlogged. Any chance this gets some attention finally?

This won’t let me work on UE4 while my wife uses an emulator to play with the controller.

oh you guys are so happy here. how about the bug that has the controller changing menu focus for no reason when touched.

I understand your frustration. Be sure to vote on the bug here if you haven’t already: Unreal Engine Issues and Bug Tracker (UE-53000) I checked and it also does it in SM5, not just the mobile preview, in 4.26.2.

Any reasons why this is marked as a “Won’t Fix”?
Hoping this gets taken care of, despite being 5 years old. I discovered this today and it’s incredibly frustrating, I have two Unreal projects open simultaneously and no matter which Play Mode I’m in, I keep moving a highlight in the other Unreal window, opening and closing stuff by accident.
The gamepad simply shouldn’t latch onto every instance of the editor, and at the very least, this should be an opt-in feature. It’s cool to have more accessibility options but this is just undesired behaviour.

1 Like