Download

Bug. FullBodyIK breaks for models imported at non 1 scale

Hi all,

I am dealing with a FullBodyIK issue which persists both in 4.26 with the PowerIK plugin and now in 5.0 with the ‘official’ FullBodyIK one.

tldr: Anything imported not at 1 .0 scale explodes as soon as a single Effector is added to the FullBodyIK node.

I noticed this in one of my models that is exported from blender not at 0.01 unit (aka Unreal 1.0) but to isolate the issue I took the standard 3rd person mannequin and exported it to FBX. I then imported it twice, once with default settings and once with scale of 10.0.

I created new Control Rig and imported my models, I then added FullBodyIK node and added a single Effector to one of the foot nodes (please not that i’ve tried the full setup first, but this is the minimum case to replicate).

Model imported at 1.0 looks like this:

Model imported as 10.0 looks like this:

I was unable to compensate for the scale by setting scale on any of the effectors or control. I can also see that the Global Scale of the model is forced to 1.0 (while Initial Scale is 10), I am also unable to affect that by any of the control I tried.

UnrealEditor_IL3ETe5ajg

Any workarounds? Is this a known bug?

Hi there. I am the developer in charge of Full Body IK in UE5. Thank you for reporting this issue.

This definitely looks like a bug. I have added it to our bug tracker and will ensure that it is addressed as soon as possible.

In the meantime, the only workaround I can recommend is to prescale your Skeletal Mesh in your DCC application and use an Import Scale of 1.0.

Kind regards,
Kiaran