[BUG] Drop down menus flicker - 4.13.2 - Mac

Some times when right clicking on a mesh and trying to attach it causes the “Attach to” menu to flicker. This is not happening only to that particular menu though, it can happen to any given menu you right click in the editor, even in blueprints.

Conditions and reproduction of the bug.

It is just random. Same conditions on the same mesh, some time it flickers sometimes not. It is hard to reproduce the bug because of this.

I have tried using different screen resolutions with more real estate up to 2880 by 1800. Just in case the menu going out of bounds is the cause , but still no luck. It keeps happening randomly.

I have tried using different monitors. Same results.

This was also happening with Unreal Engine 4.12.5. Actually is is happening with every version down to 4.10.4 (don’t have older than that installed).

I have tested it on a new level, on a new project on every version down to 4.10.4. Same random behavior.

It started happening after upgrading to macOS while using 4.12.5 and continued with 4.13.2.

Hardware and OS used.

I am using a Macbook Pro 15" Retina (late 2013)

CPU: 2,3 GHz Intel Core i7

RAM: 16GB 16000 MHz DDR3

GPU: Nvidia GeForce GT 750M with 2048MB with CUDA Driver Version: 8.0.46, GPU Driver Version: 10.12.68 355.10.05.05b16

OS: macOS 10.12.1.

I also use an external monitor besides the main display.

Hi Sutorcen,

A couple of questions about this bug:

  1. Does this only occur when using a second monitor/Have you tested with the MacBook Pro screen only?
  2. When using the external monitor do you use UE4 on both monitors and, if so, does the flickering occur on both?
  3. What type of monitor is the external monitor and what’s its native resolution?


  1. I have tested it also using the MacBook Pro’s screen. It occurs there also but again, randomly.
  2. Yes I use UE4 on both monitors and yes it happens on both of them. I even tried moving the windows between them when it occurs, plus I disconnect the monitor for the driver to “refresh” the signal but it doesn’t solve the issue either when it occurs.
  3. I use two different monitors (I work in different locations) and both are manufactured by Samsung. The first is a SyncMaster 226BW with a native resolution of 1680 x 1050 and the second one is a Samsung SyncMaster T260HD with a native resolution of 1920 x 1200. Both are used using the HDMI interface (the SyncMaster 226BW with an HDMI to DVI adapter).

I also have some other recurring bugs. Like the Blueprint thumbnail bug and some Epic created projects (Infiltrator for instance) refuse to load even though they were loading just fine before 4.12.5.

I’m testing this with the exact same Mac model with the upgrade and am not experiencing this issue. Just to clarify, when you tested with using the MacBook Pro screen only, was this with all other hardware/monitors (besides keyboard and mouse) unplugged?

If not, please try this so we can narrow down the source and isolate the addition of a monitor as a factor. If this is happening regardless of whether a second monitor is connected we can focus on just the Mac.

As for the other bugs you mentioned, we only address one bug per post for tracking purposes. If they have not already been reported please start new posts for the Infiltrator demo not loading and Blueprint thumbnail bug -thanks.

I will do so for the other bugs if the have not already been reported, thanks.

Just be sure I worked today using only the main monitor and I can say with 100% certainty that this is happening regardless of whether a second monitor is connected.

Please Navigate to:

Unreal Editor>Preferences>Plugins>Graphic Switching>OpenGL: Allow Automatic Graphics Switching

Then at the top of the Viewport, Switch to the Intel Iris Pro (leave it highlighted in gold) Does the issue occur while using the Intel Iris Pro as the rendering device?

Now hightlight the NVidia GeForce GT 750M (again, leave it highlighted in gold) Does the issue occur while using the NVidia GeForce GT 750M as the rendering device?

Please respond with the results.

Here is the thing. It hasn’t happened for a few days. I will try that as soon as it happens.

Ok, so as luck would have it, it happened. I did as you have instructed but the graphics card used by the Editor seems to stay at the System Default no matter what I choose.


I also did some testing and I can now reproduce the bug at will. In the editor the only menus that flicker are the Attatch To in the Viewport and the Move To in the World Outliner. All the other menus seem to snap at the bottom (in the Viewport) or the right (in the World Outliner) of the screen when the displayed menu would otherwise go out of bounds.

How to reproduce the flicker.

Just right click on any mesh near the edges of the Viewport on a level with many meshes in it and try to Attach it to another mesh. The menu that appears if it is near the border of the screen will flicker.

If you try it on a new map just make sure the Attach To menu appears near the right border of the Viewport, at the bottom it will not work since the Attach To list will not be populated with many meshes and thus will be too small to go out of bounds. This also happens if you try to Attach a mesh from the World Outliner.

Now the Move To menu in the World Outliner will flicker if you have a folder with a long name in the World Outliner, which will cause the Move To menu to be wider than normal and thus going out of bounds.

If you resize the Editor’s window and make it small, the flicker does not happen when the menus go out of the Editor’s window bounds.

Those two areas, the Viewport and the World Outliner are the only ones in the Editor (as far as I can tell) where the flickering effect happens.

Later today I will try to reproduce the bug in 4.14.0.

I have tried multiple times but I am simply not able to reproduce this. Please try with UE4.14 and let me know if you are still experiencing this.

Hi Sutorcen,

Since we have not heard back from you in a while, we are marking this post “resolved” for tracking purposes. However, if you are still experiencing a problem with menus flickering, please respond and let us know if this is still occurring in UE4.14.



Sorry was about to get back to you on that.

So I have tried to recreate it in 4.14.0 using various settings and projects and it seems to be fixed in that version.

I have to note though that all the other menus seem to “know” where they are supposed to spawn if they would otherwise spawn out of bounds. Those two though, Attach To and Move To, seem to spawn out of bounds and then move in the correct position. Maybe it is something to look into. So in essence they “flicker” once so to speak while the rest spawn smoothly. At least that is how it looks to the naked eye. So, yes I would call it fixed.

Thank you for your time.

This was still happening to me on 4.22 (we haven’t updated to newer version for our internal studio reasons). I suffered for weeks until I disabled this checkbox: Edit → Editor Preferences → Enable Window Animations.

Oh my god, thank you so much! I’ve been having this problem for months. Literally just made a forum account to upvote this. I’m at uni and we have to use a certain version of Unreal so I’m not in a position to update either.

As you can probably tell, this has been driving me up the wall xD

Yeah it is one of those bugs that drive you crazy.