[BUG] Disappearing Event Graph - cannot get it back!

Hi guys,

I’ve a fairly nasty bug that is affecting my work. It is possible to completely lose event graph in certain Blueprints, and once lost, it cannot be gotten back.

Reproduction steps:

  1. Create a native subclass of UDamageType (Blueprintable, BlueprintType, MinimalAPI) - it needs no members.
  2. Create a Blueprint of this new subclass.
  3. Close event graph window.

event graph does not appear in My Blueprint tab. Closing editor without saving anything does not alleviate this issue, as this is now permanent for assets of this type. I have tried reparenting UDamageType to AActor, as well as removing const in UCLASS macro, and it has not solved anything.

This could put a serious dent in people’s workflow - so please help me get my event graph back!

As a side note - there’s a typo in UCLASS macro for UDamageType (UBlueprinable instead of UBlueprintable).


I’ll second this, i accidentally closed event graph on my Character Anim Blueprint, and cannot get it back!

real bummer, if someone knows a workaround or a console command to get it back, that would rock.

Cheers to all boffins!

So you don’t see Event Graph in left panel above your list of functions?

" event graph does not appear in My Blueprint tab."

No, it’s not there and it appears there is simply no way to get it back. Once a blueprint is in this state, it cannot be fixed.


Thank you for your report. We were not able to investigate this on engine version you reported, but there have been many version changes to UE4 since this question was first posted. With a new version of Engine comes new fixes and it is possible that this issue has changed or may no longer occur. Due to timetable of when this issue was first posted, we are marking this post as resolved for tracking purposes.

If you are still experiencing issue you reported in current engine version, then please respond to this message with additional information and we will investigate as soon as possible. If you are experiencing a similar, but different issue at this time, please submit a new report for it.

Thank you!

Yes there is a way to get it back. Follow these steps

Click on Blueprint
Find Results
Search “EventGraph”

There you go its back. Cant see how your a “STAFF” member as you clearly have no idea how to use Unreal Engine.

STAFF EDIT: advertisements removed

Thank you for posting an answer, but this post is almost 2 years old. response from was an effort to follow up and see if issue still persisted for original poster several months later as we got caught up with all thousands of bug report posts. I assure you: knows how to use editor.

links in your answer were removed because they are clearly not part of your answer. Please refrain from advertising yourself on AnswerHub.

I hit this condition today in 4.11.1. I was able to fix it by closing all of other tabs (Construction Script, viewport, functions, etc.) and then closing and opening blueprint. It brought back Construction Script and Event Graph tabs when I reopened it. I had to go to “Window > Viewport” to then restore viewport tab.