Download

Bug: Deleted stuff haunting my project.

So, I was messing around trying to make some sidescroller game systems in a project called CustomSidescroller1. Then I wanted to try to rework some of the Blueprints, but I didn’t want to mess up what I already had in case I needed it for reference later, so in the launcher, I right-clicked my project and chose ‘clone’ and called it CustomSidescroller2.

Then, in the Content Browser I copied the folder that all of my stuff was in, made changes to the new Blueprints, and then deleted the old folder.

My problem is, every time I reopen the editor, the old folder comes back (seemingly empty)… And 1 of my Blueprints is messed up because a variable keeps getting replaced by an old variable of a class that doesn’t even exist anymore… And the nodes aren’t connected and my game doesn’t work. So EVERY TIME I have to delete the 2 nodes of a “PlayerCameraManager” variable (that doesn’t even exist), and put back the “PlayerCamera” variable that should be there.

Pics:
http://i.imgur.com/ri6l3Sj.png
http://i.imgur.com/7yYzN7q.png

This is extremely annoying and I don’t know how to correct it.

Hey kenmorechalfant,

If you navigate to your content folder in Windows Explorer, does this folder exist? Also, in the Content Browser, can you enable Filters>Other Filters>Show Redirectors and look in the folder?

-Matt W.

So I think I’ve resolved both issues:

I did find the folder in Windows Explorer, deleted it there and restarted the editor and it actually worked.

Then there was still the Blueprint issue. Instead of deleting the nodes I tried moving them out of the way, creating another whole new variable for my camera reference, and connecting those as normal… Save, restart… And the Blueprint was still as I left it. THEN I actually deleted the pesky nodes that I had just moved out of the way… And saved and restarted and they didn’t come back.

Seems like everything’s back to normal… for now.

I’m glad you were able to resolve the problem. If you try cloning the game again and run into problems, let us know. There could still be a bug in there somewhere that you simply found a workaround for. Any additional info is always appreciated!!

Thanks,
Matt W.

So the Blueprint issue came back! But I found another fix… Although I believe it’s still a bug, though I’m not sure how it happened.

Whenever I name a variable ‘PlayerCamera’ in this project (doesn’t happen in other projects), it’s somehow corrupt. Whenever I restart the editor it gets turned into a different variable called ‘PlayerCameraManager’… In fact I noticed if I copy-paste a get or set node, or duplicate it, the new one gets turned into this weird, non-existing ‘PlayerCameraManager’ variable, which I can’t edit…

I think the issue stems from when I was messing around with a custom camera manager Blueprint; I must have had a variable named ‘PlayerCameraManager’ that was of the type ‘MyCameraManager’ (or whatever it was), and when I deleted that Blueprint (I ended up just putting camera logic in the controller), it corrupted this variable… Which I ended up deleting or changing to just a reference to a camera actor (which is what I’m currently using).

So how I have solved this problem is renaming the variable to just ‘Camera’… Now when I duplicated the node, or restart my project or whatever, everything seems to be working fine.

If I have time, I’ll see if I can reproduce it in a fresh project.

If you repro in a fresh project, could you upload it and PM me the link? If not, is there any way you can send along your current project?

-Matt

Hey kenmorechalfant,

Looks like this occurs in any BP with the PlayerController parent class. I’ve entered this bug in our database as UE-12191

-Matt W.