[Bug] [Critical] Editor Crash on specific blueprint (opening, rightclicking, starting game, entering project maps&nodes)


i got a huge problem. I guess i know where it did come from, but i can’t get it fixed.

First of all, i don’t wont to copy my game into a new project. It’s weeks of work big.

What is the problem:

I compile the game and the editor starts. When i want to enter my Character or HUD Blueprint, the Editor crashs and says “Kernelbase.pdb not loaded”.
It also crashs if i want to start the game or when i want to open the Gamemode Blueprint as well as the projectsettings for setting the Maps and & Modes.

When did i do before the problem came up:

I got a Custom GameMode Class that added the Character and HUD Class by searching the Blueprint in the Folders. (Like it was made in the First Person Tutorial).
I worked with that some weeks and wanted to change the folder structure. So i moved the two Blueprints one Folder deeper into an extra folder.
I forgot to change the lines in the GameMode and compiled again. It said, it couldnt find the Blueprints, so i changed the GameMode to a second one where i set the 2 Classes per hand.
After i closed the editor again and changed the reference address of the Blueprints i recompiled everything it the crashs began. I cutted the lines an tried to compile without them, and with them, and with the old ones and so on.
I can’t get it fixed.

If i open the Project from the Launcher (the one without the compiled code) i can open the blueprints. But not in the compiled version.

How can i fix this? I cant delete the GameMode Blueprint and neither can i access the Project options to change something.
I also can’t migrate the Blueprints to another project, cause rightclicking crash the editor.

AND i can’t give you the project, because the inet speed is so slow, i would take weeks to upload the files.

): I hope you know a fix, because i can’t find one by myself.

EDIT: Error in the Log File

[2014.08.08-16.14.26:464][115]LogWindows: === Critical error: ===

[2014.08.08-16.14.26:465][115]LogWindows: Bad name index 10496/1554

[2014.08.08-16.14.26:465][115]LogExit: Executing StaticShutdownAfterError
[2014.08.08-16.14.26:472][115]LogWindows: FPlatformMisc::RequestExit(1)
[2014.08.08-16.14.26:472][115]Log file closed, 08/08/14 18:14:26

And tons of lines like this:

[2014.08.08-15.55.43:343][ 0]LogBlueprint:Warning: [BP_SurvivalCharacter] CreatePinForVariable: ‘SelectedItem’ variable not found. Base class was probably changed.
[2014.08.08-15.55.43:343][ 0]LogBlueprint:Warning: [BP_SurvivalCharacter] CreatePinForVariable: ‘SelectedItem’ variable not found. Base class was probably changed.

Hi eXi - could you post your logs? They should be in your project directory’s saved/logs subdirectory.

Array Inner Type mismatch in Recipes of BP_SurvivalCharacter_C - Previous (ObjectProperty) Current(StructProperty) for package: …/…/…/…/…/…/Users/Cedric/Documents/Unreal Projects/SurvivalQuestGame/Content/Blueprints/Character_And_HUD/BP_SurvivalCharacter.uasset

Was this warning present before the asset became corrupt?

You’re unblocked, then? I’ll get back to you with an explanation of the crash. I might not have a good one until Monday.

Thanks for the bug report and all the details!

From what you explained it could be the problem is when you try to open the blueprint, or start the game ,
the engine is unable to find the asset and crashes.
If you think the problem is with the engine not the project, then try Verifying the engine in the Unreal Engine Launcher menu.

Yeah, my last log is this:link text

link text

I also have this huge one, but i don’t know how to make it again.
I guess i was one of the version where i assigned the blueprints by code again.
I deleted some lines, cause i was way to big to upload, but the lines where just all the same telling something cant be find.

No, it’s because he can’t find the asset. But even if write down the code to assign the 2 Blueprints to the GameMode with the new address of the, it crashs.
I can’t move them back, cause this crashs too.

Oh wow, you are a god o.o
I added an Array in between that i already forgot about, because i got distracted by the GameMode Error.

Deleting this line in my character.h

UPROPERTY(BlueprintReadWrite, EditAnywhere, Category = InventorySystem)
	TArray<FItemRecipes> Recipes;

seems to have fixed it. I guess i missed a “*” for the Pointer or?

I hope that fixed it, i will accept your answer if my GameMode is working again. Just answering you quickly, so you don’t wait for me.

EDIT: Ok, it’s working, but i didn’t miss a pointer. It’s a struct from another header file that i included to the character.h. Why is it crashing?

EDIT: Ok, i guess the name “Recipes” was used in my Blueprint, but not as the Array Type above. It was used as another type i tried before but didn’t delete it in the blueprint. I guess that’s the problem. Strange that my Project Settings and GameMode also broke from that.

Similar things happen when blueprints can’t find variables or other assets and crash or just don’t compile. I see you got it working, great !

Yes, i’m unblocked. (: Thank you very much.