[BUG] Cooked version serious performance drop


I am running 4.11.2 and I was doing an interim cook just to check everything is fine. We do these checks time from time to ensure the game is still buildable. Last check I did was with 4.10.x and the cooked version was much, much faster than PIE.

With 4.11.2 I run game in Editor on fullscreen and epic details with 25-60 FPS. Packaged version (Win64) dropped down to 6-12 fps. Apart from FMOD we don’t use any external plugins.

Any idea what can be checked? We encountered this for the first time - we tried to do this since 4.7 up to 4.10 and we never had this issue.

Thanks a lot,



Ok. I tried to do both WIN32 and WIN64 build of the project. Both manifest the same issue. I captured Editor running at fullscreen / epic quality and default configuration of the cooked build. I tried both pak and separated version of the build.

Eventually I found out, that cooked version regardless of settings drops to 1/2 - 1/4 of framerate in comparison to the PIE in same resolution.

I cooked development build and captured the (almost) the same view with stat unit on. The white arrow is just a cursor which doesn’t affect performance at all. This is the result:

PIE version:


Cooked version:


I also tried to check if quality has a say to this so I tried:

sg.TextureQuality 0
sg.ShadowQuality 0
sg.EffectsQuality 0
r.DetailMode 0
r.PostProcessAAQuality 0

The result is performance-wise horrible if way more ugly. :slight_smile:


Further profiling with stat SceneRendering showed me that the issue lies in:

Deferred Shading Scene Renderer Render Init

It takes 99% of Draw thread! If I compare it to the PIE version, that item is not even there. So I guess I found a culprit.

OK. I solved it… r.SetRes 1920x1080f fixed the performance issue. In other words, you MUST run the game in fullscreen and exactly the resolution the monitor is running or the performance is going haywire.

Running in stable 35 fps now.

As a sidenote, if you (even in game) change resolution to something else, the game is destroyed. It’s sluggish and all sorts of flickering occurs. Also if you run the game in a different resolution from start (through Saved\Config\WindowsNoEditor\GameUserSettings.ini) it won’t help. At this point you can play the game only in exactly the same resolution as your desktop is.