[BUG] Compiler errors when creating new Third-person project

[Build info]
C:\Program Files\Rocket
version 1627304

Processor: Intel(R) Core™ i7-3770 CPU @ 3.40GHz
OS: Windows 8 64-bit
System Type: 64-bit Operating System, x64-based processor
Graphics adaptor: NVIDIA GeForce GTX 650 Ti BOOST (2GB edition)
Integrated graphics adaptor: Intel(R) HD Graphics 4000
Visual Studio 2012 Express installed before installing Rocket.
DirectX SDK installed on 16 June 2013 (newest version at the time) after installing Rocket.
Optional Downloads have not been downloaded yet (such as the ShooterGame folder).

Third-person Project fails to create, due to compiler errors.

[Repro Steps]
-Open Rocket Editor.
-Choose “Third Person” from the New Project menu.
-Wait a few moments.
-Message window pops up: "Failed to compile ‘C:Users/mightyenigma/Documents/MyProject2/MyProject2.uproject’. [Ok]
-Click [Ok].

Message Log - Compiler Log Shows the following lines:
-Generating code for MyProject2
-link.exe RocketEditor-MyProject.dll
(X)LINK: fatal error LNK1181: cannot open input fild ‘wininet.lib’

  • ------- End Detailed Actions Stats --------
    -ERROR: UBT ERROR: Failed to produce item: C:\Users\mightyenigma\Documents\MyProject2\Binaries\Win64\RocketEditor-MyProject2.dll
    (X)Cumulative action seconds (8 processors): 0.00 building projects, 8.19 compiling, 0.00 creating app bundles, 0.00 generating debug info, 0.10 linking, 0.00 other
    -UBT execution time: 12.31 seconds

I thought I would get a ready-to-playtest 3rd-person project in the Editor, but got this error instead.

I also have this issue, i think its something to do with the c++ redists, i had to uninstall previous ones to install VS 2012, im sure they were installed by UDK previously, unless its figured out i might uninstalled UDK, any c++ redists for that, rocket, VS directX SDK and try again, i recently did a windows 8 refresh, not up for it again.

software image

Iv attached an image of my installed software(for epic engineers), is there anything im missing? or are there any C++ redists that are not present for what ever version number?, its going to be a real shame if ue4 requires everyone to reinstall windows to get it working.

Installing VS2012 Express for Windows Desktop (not for Win8) solved my problem! Thank you for guiding me to that answer.

I had a similar issue. I could make new projects, but not for C++.

One thing I noticed is, they require Direct X SDK June 2010. Your’s may be different.

I had multiple versions of Visual Studio and Direct X, and .Net, as well installing to another drive. I gave up on trying to figure it out and did a fresh install of Windows, VS, Direct X SDK, and then Rocket. It then worked. That isn’t an option for most people I know. My C: drive is a smallish SSD so I try to keep what’s on it limited, my main storage drives are unaffected by wiping the boot drive. I was impatient to find a real answer is why I did that, but it worked.


that might be it - I installed several games after installing Rocket, and some of them installed VC++ 2005 redists and directx 9.

-League of Legends
-Unreal Tournament 2004

I wonder if this has anything to do with the render glitches I’m experiencing too.

i will try uninstalling/reinstalling in various ways.

I tried uninstalling and re-installing everything in the order you mentioned - I also got rid of all the VC++ redists. I still get the exact same results.

I also searched my hard drive for wininet.lib and it does not exist.

Should I get VS2012 express for Windows Desktop or for Windows 8? I am running W8 OEM

Sorry, Visual Studio Express for Windows 8 is not supported for Rocket. That program is used for making Windows Store apps, and is not really suitable for the Rocket development environment. You’ll need Visual Studio Express for Windows Desktop, which includes the libraries needed for compiling desktop programs.

hi, iv done this and i get a new error please see my comment about about the .bat file now missing

Hey Marc. Can you check to see what your VSCOMNTOOLS11 system environment variable is set to? You can open a command prompt and type “set” to see the list of environment variables, or go to Control Panel → System and Security → System → Advanced System Settings → Environment Variables. Thanks.

VS110COMNTOOLS=B:\Program Files (x86)\Common7\Tools\ when i installed everything (rocket, VS, DX SDK i always change my paths to my b drive because my C drive is only a 64GB SSD with very little space left on it.

So you have the environment variable, but you can confirm that the folder it points to doesn’t exist on your computer after first installing Visual Studio 2012 Express for Windows 8, uninstalling that, then installing Visual Studio 2012 for Windows Desktop? If that’s the case, something seems horribly wrong with the Visual Studio installation process. Is it possible that you chose a different folder for either version, and the environment variable is out of date? Also, can you try running the Visual Studio 2012 Command Prompt from your start menu, and see if that produces and errors?

the only folder in common7 is IDE, i have hidden folders set to shown so its not hidden either.
Not sure how the environment variable would be out of date, opening the CMD just brings up a C:/WINDOWS\system32> when run in admin and a B:\Program files(x86)\Microsoft Visual Studio 11.0> when ran without admin rights, im thinking of just completely removing everything including rocket and starting again, but i have no idea how to clean everything up completely after uninstalling.

The Wininet.lib can be found in several Windows SDKs or Windows Kits.

This includes Windows SDK v7.0A and Windows Kit 8 for Win8.

I believe that installing VS2012 Express for Windows Desktop (which is what I personally used for testing Rocket on a clean machine) properly installs this - but for Windows 8 may not. We will investigate this.

Did you both install Express for Windows 8?

I had Win 7 64 bit. Before I re installed Win 7 I had VS 2008, 2008 redist, 2010 Pro, 2012 Ultimate Beta, and 2012 Express. I think I had the Windows SDK in addition to the Direct X 2010 June. Plus many other Microsoft related installs that went with all that.

After I reinstalled Win 7, I only put Direct X 2010 June and 2012 Pro before installing Rocket and it works fine for me now.

I installed express for win 8 because it includes the options to make windows store apps, something else im currently doing, should i have installed a differnt version?

Installing the Windows Desktop version of Visual Studio Express 2012 fixed the problem! That was it - The Win8 version doesn’t have the required libraries for Rocket.

Iv uninstalled VS 2012 express for windows 8 and isntalled the desktop version instead the compiler log now only has one error but im not sure where something is missing. i dont even seem to have a tools folder in the common7 folder so no hope of knowing what them …/…/ paths are.

ERROR: SetEnvironmentVariableFromBatchFile: BatchFile B:\Program Files (x86)\common7\tools.…/…/VC/bin/x86_amd64/vcvarsx86_amd64.bat does not exist!