[Bug] Child blueprint values resetting on editor restart

Exact problem: Skeletal mesh component resets to none in an Player_Character child blueprint after an editor restart.

This seems to be an old bug, and it started appearing again since latest patch (4.9.2). This seems to be same problem:

They are from different time points, and it was mentioned that it was fixed in 4.9.1. latest patch broke it probably again, or it was never really fixed.

Yep, that’s a real classic. only workaround for this is to recover corrupted blueprint from a backup (normally last saved version from project’s ‘backup’ or ‘saved’ directory works.

Using an old version didnt work (tested multiple versions with GitHub)… I ended up looking trough all referencing assets, and removed some circle references. That seems to have fixed it for now. (I am still not sure if that was cause for bug)

Hey D4nlel,

Glad you got it working! This bug is definitely a result of circular referencing, and we have a bug report in for issue (UE-18765) that includes occurrences in 4.9. I’ll add your information and your fix to report. Thanks for letting us know!

Darn I get this too in 4.10.2

Have a weapon BP and in that one I have a variable that holds my projectile main class (has bp children too), that variable turns to Unknown place holder on editor restart .
In my weapon bp children some variables gets reset to mains variables :confused:

Now after upgrading to 4.12 I have same bug that is described. Just odd it was not fixxed after so much time.

It started happening to me too in 4.12

Same as two people above, just update my project to 4.12 from 4.11, and now one of my child BP’s keep resetting settings like collision, and widget(3dwidget component).

I also want to mention, that BP was created long ago in 4.9, maybe even 4.8. If it’s matters.