[Bug?] Blueprint continues to run when Paused in editor and using server/client networking

Came across an odd bug, or at least I think it’s a bug. I’m not sure because I’m pretty new to networking as a whole. Anyway, gist of it is that my game seems to continue to run even though PIE editor is paused, and I’m not sure why.

So what I have is essentially a minigame that is played by multiple players. server spawns room, room detects if players have entered room, and once they have, it runs a timeline where tiles in room are randomly chosen to shake, then fall. Once one player is left, room finishes, rewards players, and opens door. This usually works perfectly in my previous tests, but as you can see in gif I linked in imgur link here (Imgur: The magic of the Internet), tiles aren’t falling, and most importantly, blueprint is running when editor is paused. Let me know if you’d like to see blueprint. It’s a bit messy and large, but explanation above is more or less shortened version of what happens.

I noticed that this bug has happened one other time for a different minigame room with same MO. room works perfectly in other situations when placed directly into level, but when spawned from a blueprint, and when there are two players, blueprint will refuse to pause when editor is paused, as well as refusing to work correctly. I have since made a work-around and changed first room that this bug has happened to, so I’m unable to replicate bug. I’ve also attempted to reinstall UE4, hoping that it was just a one-time problem, but it seems that this was just wishful thinking.

Any clues as to how to fix this problem?


I’m not sure I understand, so let me ask for a bit of clarification. It looks like you’re pausing simulation, not pausing in game. And when you do, part of tile blueprint runs (shaking part), but not falling part. This only happens when playing with 2 players in PIE, and only when blueprint is spawned during PIE rather than placed in level prior to PIE. expectation is that pausing PIE will result in none of blueprint running.

Is all that correct? Please let me know if I got any of it wrong.

My guess is that timeline has already started when simulation is paused, and falling part is outside of timeline. Is that correct? So problem might be that timeline isn’t stopping.

It would be very helpful to see blueprint, if you don’t mind. Does it have any dependencies, or can i just drop it in a project to test it? If it’s easier to show me in project with which problem occurs, you can upload that somewhere and send me a link via forums PM.

I’m also not clear: you managed to create a workaround for one room, and so you can’t reproduce issue in that room. But you can in others? Is it consistent, and happens every time? If not, how frequently does this occur?

If you can provide any more specific details as to your workaround or functionality of blueprint in question, and circumstance in which this occurs, please let me know. Thanks!

Yes, I’m pausing simulation, and I’m expecting timeline to pause with simulation, which it usually does if I recall correctly. shaking part is in fact part of timeline, but dropping part is a function in tile’s child actor’s blueprint, which is called in timeline. And yes, this only happens when playing with 2 players in PIE. In another level, I placed room directly into scene and it worked fine, but when spawned into scene using my procedural generation blueprint, this behavior happens. expectation is that pausing PIE will result in timeline pausing, so that I can check what is working correctly and what isn’t. I believe it might not just be timeline that continues to play, because even nodes that are placed after timeline’s “Completed” line/node/connection/thing are playing while simulation is paused as well.

Are timeline’s supposed to run when I pause simulation?

I can send you a .rar of my project via PM over google drive, could you show me where I can send you that privately?

And yes, I created a workaround for one room, but haven’t thoroughly tested if it still works, or if bug is even fixed thoroughly. I thought I had fixed it, but I just realized that I’ve been testing it without using my procedural generation to spawn room, so I’m not sure if It’s actually working. This has only happened twice to me, two times I’ve mentioned this. Both use timelines that run events that happen in room. In this room, what happens is a timeline changes material of a monster from black to red, like a ticking bomb. After timeline ends, monster explodes. When simulation is paused, timeline continues to run, changing material of monster, and eventually finishing and exploding him.

Um… one other bug that has happened to me recently that I have been unable to reproduce that might be of help. When working on blueprint class of one of my game rooms, for some odd reason, blueprint was running, despite never having pressed play on PIE editor. Namely, nothing was moving, but my Print String nodes were all playing in correct order, then after some time, I would see my Spawn Actors spawn coins (a reward system I have for finishing a game room). coins would simply be in blueprint class viewport, but wouldn’t show up in list of objects in blueprint class, nor could they be clicked. After I had this bug, I closed UE4 and restarted it, and haven’t seen this bug again.

No, timelines are not meant to run while simulation is paused, just wanted to be sure I’m understanding you correctly.

You can send me download link here:

In your message, please include steps to reproduce in project, including which map to open and any other incidental requirements that you can think of. If you can provide name of BP to focus on, that would also be helpful. Since this is only an occasional bug, I may not be able to reproduce it, but I’ll at least see if I can spot anything that would cause this. Thanks!

Okay, I sent you message in UE4 forums. Let me know if you recieved it. I don’t check UE4 forums often, but I’ll check when I can.

Hey, sorry, forgot to mention that I did get project, and I can see what you’re describing. I’ll be investigating further to see if I can find cause and entering a bug report once I do. I’ll keep you updated here.

Hey ,

Thanks for project! I was able to reproduce this in a much smaller project, and it appears it’s as simple as timelines not pausing properly during PIE if there is more than 1 player. I’ve created a bug report for issue (UE-23781), and I’ll post here if I see an update.

I believe problem you’re having with blocks not dropping is unrelated, and I would recommend creating a new post for that in Blueprint Scripting section as I do not believe it’s a bug but a workflow issue. If you PM me with a link to new post you create, I’ll see if I can spare some time to look into it further.

Thanks again!

Thanks for help , much appreciated. No worries on blocks not falling, it just so happened that I was trying to fix up blocks when I noticed bug, so I was unsure if it had any relation whatsoever. In meantime, I found out why my blocks weren’t following, which was indeed due to something I did wrong in my blueprint rather than a bug with Unreal, so that’s fixed.

Thanks again!