[BUG] Apply radial damage is not received on attached actors when simulate physics set to ON

I have a BP setup of an airplane made out of multiple BPs attached together. The root of the airplane BP is a collision sphere component. On BeginPlay I spawn fuselage, wings and tail BPs and attach them to Airplane using Attach Actor to Actor with WieldSimulatedBodies option.

Everything is working fine, I have collision working with projectiles, landscape and etc. Each part of airplane can individually receive Hit and Receive Damage events.
The only issue I’m experiencing right now is that Apply Radial Damage works only if my root Sphere Collider doesn’t simulate physics. If I switch off simulate physics, then radial damage is received as expected. But by switching it off I loose collisions with landscape and other objects as fuselage, wings and other parts of airplane are wield attached to Airplane’s root sphere collision.
I suspect that something is wrong with a way how Radial Damage traces if actors in question can receive damage or not. I’ve tried different setting where root collision sphere and airplane parts would react to Visibility channel, tried resizing them. The only thing which seams to have an effect is if simulate physics is enabled on root or not.

More testing and it want to note that Airplanes Sphere Collider is very small, so it’s always covered with airplane parts.

When Simulate Physics is OFF:

  • Airplane BPs doesn’t receive Radial Damage as it’s root Sphere Collision component is covered with fuselage and other airplane parts.
  • Airplane Parts are receiving radial damage as expected

When Simulate Physics is ON:

  • Airplane BP starts to receive radial damage
  • Airplane Parts now ignore Radial Damage

I’m sure it’s related to a fact that actors are attached to each other.

I’ve made a very simple test scene and it looks like it isn’t an issue with my setup, look more like an engine bug.
This is a simple test project where two boxes are attached to the left and right from a central box - their collisions or bounding boxes don’t overlap. Boxes receive radial damage until Simulate Physics is enabled on central box. Switching it off/on after that doesn’t change the behaviour:
link text

Hi BoredEngineer,

Thank you for the report and the test project. I was easily able to reproduce the issue. I’ve created JIRA UE-11939 in our tracking software and our developers will be investigating it further. We will post back here with updates as we have them.

This may not be a workaround that you can use but it may give you some ideas. During testing I did noticed that if the static mesh components aren’t welded, the radial damage is received correctly with physics on or off.



Thank you, TJ!
I think I’ve tried that, in case of airplane if I don’t wield pieces they simply disappear. Perhaps collision is overlapping or the fact that root of the system is kinetically moved around. But I’ll definitely try it again. Thanks!