[BUG] Anim BP Root Motion from Anything and Jumping

So i’ve noticed something, which i’m pretty sure is a bug.
If you have an anim BP set to root motion from anything, and then you jump on a client, the client for some reason stops being able to get the velocity of the actor until it stops and moves again.

So if you had Root motion and jumped your character would appear to slide around on the owning client. (Due to server-side correction only)

Hey RossenX,

Any chance you can show me a video of what you mean? I’d like to get a sense of your setup too. If possible, could you migrate some of your content to a clean project and send it to me? Might be easier that way. You can PM me a download link on the forums if you’d like to keep it private.

-Matt W.

Hey there, so i’ve narrowed it down to what’s happening.
When my character gets corrected by the server, it breaks and you have to stop, and then move again for the client to start seeing the velocity again.

Steps to replicate it:

  1. Start a new third person project,

  2. Add a cube, turn on simulate physics

  3. Turn on “Root motion from everything” in the Mannequin AnimBP

  4. Walk into the box

The player will now be completely moving from the server-side correction and the client pawn has no velocity or anything. This will continue EVEN if you change direction. Once the player stops moving it fixes itself.

Here’s a video: UE4 Root Motion Bug - YouTube

Also note this is only on the pawn’s owning client. If there are other clients they see him walking around just fine.

Hey RossenX,

Thanks for the repro steps. I’ve entered UE-43924. You can track the report’s status as the issue is reviewed by our development staff. Please be aware that this issue may not be prioritized or fixed soon.

-Matt W.