[BUG] [Android] Playing any sound longer than 5 seconds causes the sound to trigger 3 times in quick succession

I’m a little concerned that no-one else has reported this, but I’m seeing it quite consistently. On Android, if I play a piece of music or a sound effect that is longer than 5 seconds, it seems to trigger 3 times in succession, before playing correctly. It doesn’t matter whether this is an Audio Component that I activate using the Play node, or whether I use Play Sound 2D. I saw this in my own project, but was able to reproduce it in Tappy Chicken and the SideScrollerExample project, in the former by hooking the Play node up to the end of the Title Screen animation, and in the latter by triggering it from the Game Mode’s BeginPlay event. I’ve seen it both with my own pieces of music, and with ‘Starter_Music01’ from the Starter Content.

This has been observed on a Samsung Galaxy Nexus, an LG G3, and a Motorolo Moto X (2nd Gen.).

I am having this issues as well on the Galaxy S4. The music on my title screen stutters a few times before playing correctly. I have tried attaching the sound in every way I know how: play sound at location, play sound 2D, and a sound que in the level itself. I have also tried changing the compression. Any suggestions?

I am having the exact same problem in 4.9.1, previously in 4.8.3 everything worked fine.

I observed this in Samsung Galaxy Note 10.1

Same problem as well (Note 4) - in my case it’s hard to say what is causing it exactly - some sound wavs play fine and it’s just one that has this triple stutter - I see very little difference between the wav files even the length in some cases is similar. Occurring in 4.9.1 not occurring in 4.8 and earlier

Doing this will fix it for the time being

As far I understand, this happens with ‘Adjust Volume’. Tried using ‘Audio fade in’ but same result.

It does not happen when I play the sound without changing volume at all.

That does not work for me; just tried.

It actually did work for me, but I didn’t have to do anything with adjusting the volume, I just played the audio with a start time of 0.001. I’m going to wait for word from Epic about this issue before marking it as resolved, though.

Hey All,

I was able to confirm what you are reporting here, and have gone ahead and entered a bug report for this issue (UE-21709). Although not optimal, for now I would stick with your temporary workaround of setting the start time at .001

Once this issue has been addressed by the engineers, we will begin working on getting a fix implemented for an upcoming engine release. For updates to this issue, we ask that our users navigate to our Forums (Announcements and Releases Section) or our Documentation (Release Notes Section). We post all the bug fixes in the full engine release notes, but some are added to the hotfix notes found on the forums.

Thank you all for taking the time to report this issue, and for your patience while we tested. If you have further questions, please let me know.

Thank you,

Andrew Hurley