[BUG] 4.7.5 - Timeline Finished output fires too early


Unless I am misunderstanding how the Timeline Node works, it looks like the Finished output fires too early. In the simple setup below, I am trying to fire two timeline in a row, the first and then the second once the first completes.

The first timeline is set to last 6 seconds, and the second one to is set to 2 seconds, so the second should start after 6 second, but it actually fires right away.



Hey ,

After looking over your screenshots, I noticed that ‘use last keyframe?’ is selected. This actually may be the issue that you’re running in to with the timeline not firing at the correct time. Please try to un-check that and test your project. If that does not resolve the issue you’re experiencing, please reply back with additional details.

Thank you!

Hi ,

I have re-created the node and wasn’t able to reproduce the issue with this new Timeline Node. However the new one is still not working properly. The issue happens with the old node if the Use Last Keyframe option is ON or OFF.

So, it appears that the problem is related to the faulty node.


Hey ,

After recreating the node, you were able to resolve the issue you were originally having with the timeline node, correct? Also, when you say the new timeline isn’t working, could you elaborate on what’s happening? Or were you able to fix this completely by recreating both timelines?


Sorry, this was a typo. It should read:

“However the old node is still not working properly.”

I have checked both nodes, and they are identical. So I have not idea what might be causing the issue in the old one. But creating a new one solved the issue apparently.

So, problem solved I guess.


Hey ,

Thanks for clarifying. I’m going to look into the timelines a bit further at this time. If I can find some type of reproduction for this, I’ll be entering a report to our developers this afternoon.

I appreciate you keeping me updated on this. Let us know if you have any further questions or concerns. :slight_smile:

Hey ,

I have not heard from you in quite a few days. I must close this thread for tracking purposes. If you happen to have any further questions regarding this topic, please update this thread when you’re able to.

Thanks, have a great day! :slight_smile:

Had a similar issue a few days ago. Seems like the timeline doesn’t reset it’s internal time state after finish. Did you try using “play from start” instead of “play”?

Hey ,

Are you able to tell me which version of the engine you were working in while you noticed an issue with the timeline nodes? I have tested them in 4.8.0 Preview 3 and I do not see any type of lag or delay involved with them.

Could you also show me a screenshot of what you’re running through your timelines?

I appreciate any assistance you’re able to provide, thanks!! :slight_smile:

Sorry to necro an old thread, but this bug appears to arise from copying an existing timeline. The new copy of the timeline will fire the finish trigger at the same end point of the old timeline regardless of it’s own timeline length.

Eg. You have an existing timeline that’s 1 second long. You copy it and set the length of the new timeline to 2 seconds. The new timeline will fire its finish trigger at 1 second regardless of the fact that its a 2 second timeline. This bug exists even if you reduce the length of the new timeline, resulting in the finish trigger firing late instead of early.


So this has been tested in 4.12.0 Preview 5 and we were unable to duplicate what you’re explaining here. If you have repro steps, could you please submit a new thread to AnswerHub for additional assistance.

Thank you!