(BUG) 4.11 Preview: Quick Touches causes reset location

Hey I’ve run into a bug in the 4.11 Preview 7 in which touch input seems to be bugging out in a few ways. Doesn’t block me but the previous previews didn’t have these issues so I wanted to add them here as I didn’t find them in the search.

  1. When using mouse input to simulate touch controls I have to click outside of the editor a few times before it stops the mouse from using its normal input. This isn’t a big deal, just annoying, easy work around just to click out once or twice while testing.
  2. The main issue is in the InputTouch event which outputs the Pressed, Released, and Moved and the screen location vector and finger index. Whenever touching multiple times quickly on PC it seems to be outputting the location as its reset screen position of (-1,-1,0). If you wait a moment it does not have this issue, just quick taps cause the rest location. Here is a quick video on it to show whats happening easier:

The quick work around is to use the player controller and the node Get Input Touch State as the x/y output is correct even during multiple quick taps.

I haven’t gotten a chance to see if this occurs on a blank project but will try and see if I can replicate it later. I also have not been able to try and see if this occurs on device or not yet.

Hello GPM,

I’ve attempted to reproduce your issue by printing Mouse Position when Input Touch is pressed, but I’m not seeing the same error.

Have you been able to reproduce this issue in a clean project? If so, could you provide your repro steps so we can get this to reproduce on our end?

Hey Sean, so I tried starting up a fresh 4.11 Preview 7 project and do have the same error. This occurs when I set the player controller to show the mouse and in the Project Settings → Input: Set Use mouse for Touch = True

The main problem still seems to come from the InputTouch event where the location works great if you click slowly. If you are trying to click at a faster rate or double click it will set the location to (-1,-1,0).

Other nodes which get the mouse or touch location work fine still, so again, it does have a work around to use those instead.

I’ve zipped up the new and clean project and have it here if you’d like to see my setup:


Awesome! Thanks for the update and glad to hear that its already been found / fixed. Have a good one!


I was able to reproduce your issue in the 4.11 Preview, but the issue seems to be resolved internally, and the fix will be released in a future version.

Have a great day