BSP Invisible but is showing up in Wireframe

G’Day All,

Panic mode here. Have spent the last 2 days modelling the house my husband and I are building, first home. We used BSP for the walls which was fine…until I ran a light build and suddenly the walls were gone! I didn’t save the file so rebooted the machine…came back…gone, but still in wireframe!!! I found one post pertaining to this exact same issue and a fix was to copy the geometry and remove what you don’t want…this doesn’t work. We’re trying to get this done before we do our selections on Thursday so of course panic mode and having to model it in Maya and bring it in as pieces. I know BSP can be buggy but anyone got any other solution to this?


Are they visible in unlit mode? (Alt+3)

Hey…no, they weren’t visible in Unlit mode either. So weird it happened. I know BSP can be buggy but we were so close.

(Be sure to back up all files when doing this) Can you try deleting the derived data cache and reloading?

Hee hee don’t have to worry about backups…most of my career was in IT Support so know all too well :o) We ended up modelling it in Maya and bringing it in. Wasn’t 100% perfect but a great start to the walk through and the company we’re building with was quite impressed none the less.


I also have sometimes the problem that a BSP disappear.
They are not visible in the wireframe viewports or in perpetive mode.
However they are still listed in the scene outlier. When I select the brush there, it seems that nothing happens in the viewports.
But, when I then switchto geometry edit mode, the vertices of the BSP appear, but unconnected without edge lines.

A solution that I found working in 99% of the cases is: Make a copy via ALT+drag (while in geometry mode). After the copy is crated, both brushes (original and copy) are there.
After the copy is deleted, the original brush stays visisble…

I tried to see if there were similaities… but it happens randomlöy to all types of brushes, from box to linear staircase. Hollow an solid… but 0nly to additive brushes.
I didnt bother about it that much since its relatively easy to fix (in most cases), but its interesting that other people have alsp problems with BSPs.

Curous about that post. Remeber whichone it was?


Hi RS Digital Studio,

Can you post this to the answerhub under the bug reports section? If you have any steps that you know of that reproduce this error please list them on the answerhub report. You can find the answerhub at Thank you!

I have the same issue using ue (4.20.3). What helped me was copying the box and deleting the original. However, it only worked for one out of 4 boxes. The 3 remaining ones did not gain their visibility and collision. [It happend to me when I was copying a collision box on the other end of the map I am working on]