Download

Broken lightmap

UV 0 is overlapped and used for texture

UV 1 is non overlapped made for lightmap

Settings are set for uv1

Bake result

F M L

F M L UE4 FML

it is a lie

One of the reasons could be that you don’t have any padding between your UV shells, have a look here LightmapUnwrapping

Also you can increase the lightmap resolution of the asset for better quality.

Quality? so you think that the result you see in image i provided is related to padding?

are you sure?

Yep. Have a look

Anyone with real help?

how many pixels padding do you have between the UV islands for the slats?, it looks like you only have 1 pixel padding so I would guess that’s why the shadows are bleeding as well.

also you could arrange the UV a little better and snap the UV verts to pixels.

Do you understand that despite that padding there is no way that UV should produce repeating tiled pattern all over the object, please tell me you are trolling me, because how can you miss that fact if i provided images that CLEARLY show it?

I used to get similar problems in UDK. Deleting the lightmass swarm cache helped usually. You could try the same.
The cache can be found in:


%localappdata%\UnrealEngine\4.7\Saved\Swarm\SwarmCache

Thanks man that didnt fix it but its good to know,
now for you padding guys

this are lightmap uvs that UE produces himself, please file a report that UE4 does not use padding and teach them how to do that properly.

I fixed the problem, and it is related to UE4 bug.

wait, so I give advice based on your lightmap UV that could make it better and you imply I’m a troll, nice, really appreciate it.

oh and no automated UV tool will give perfect results so they shouldn’t be relied on.

also you could have said how you fixed it so that if others have the same problem they can fix it as well.

It looks like it was just an issue that it was using the generated lightmap UV’s when you imported to UE4, if you have your own already setup, then make sure to uncheck that option when you import.
As for the UV’s, make sure you have enough space between the UV islands and that your lightmap resolution is high enough. Also make sure your lightmap coordinate index setting is set to the correct UV channel, if you have 2 channels it will by default set the second channel as the lightmap UV channel.

all wrong Having UV channel beyond 2 creates broken lightmap behavior - UE4 AnswerHub

Hi Samb,

I’m in line with darthviper’s thinking on this one. You need to adjust the Lightmap Coordinate Index to the correct channel.

From the images you’ve provided you show the build settings where you are using your source and destination lightmap coordinate as UV Channel 1. In that same picture you can see that the lightmap resolution is set to 64 under the Static Mesh Settings, but we cannot see what your Lightmap Coordinate Index is set to under the advanced roll-out.

In another image you’ve shown the UV Channel 1 layout, but this does not show where it is assigned to.

The Lightmap Coordinate Index should be set to 1 since this appears to be the UV channel that you would like to use.

Also, it’s key to know that the build settings are just that. They are a way of generating or “building” your settings for your Static Mesh, but they will not set them up automatically.

I tried all index.destination combination with the same result of tiled broken pattern, after test by Erik on answer hub im mostly certain the problem was in cache.
I can’t test it right now but the way i though i “fixed” it by deleting uv channel was actually that i Imported new mesh, with new uv, not REimported,
which means a new cache for it was built, which means i falsly assumed that was the solution.
Despite there is a way to solve this issue like in my case by importing new model, or removing the cache,
that doesn’t change the fact that i experienced a bug, in which the lightmap got literally stuck on that model in that project.
Due to what that could happen?

I’ve definitely seen this same bug before on another forum post, but unless it’s reproducible, there isn’t much that can be done about it.

I have the same problem.

I’m using Blender v2.7.4 and Unreal Engine v4.7.5. I have read everything I could, but I can not find the error. I attached pictures.
There is a small gap between the faces of the cube. I tried from Blender, different values of separation, but none works. As you can see the shadow is not correct when lighting is rebuilt. The Light map Coordinate Index is 1. I have two channels UV. The mesh is a simple cube without any modification.

I appreciate your help.

1462f9603d430a066863d8caf5a0d2171257abb3.jpeg
39509d5d0bf4dc845739b54ea6ea87273e36795a.jpeg
b1b213fe68f5908848e4a058a028e3c4f03c3fcb.jpeg

mauroretch, you should post this in a different thread, that is a different issue. You ideally need a 4 pixel game between UV islands, and you should snap to a UV grid that matches up with the resolution you pick for the lightmaps. Take a look at this explanation http://www.reddit.com/r/UE4Devs/comments/246whl/the_most_important_thing_about_lightmaps/

While you’re lightmap UVs may need a little padding between the UV islands there is nothing wrong with this mesh.

The wavy low quality shadow you see on the ground is the result of a low Lightmap Resolution for the ground plane. Not the box.

The lightmap does not handle how shadows are cast and baked onto other meshes, but how it bakes a texture for itself.

You should take a look at our Wiki Lighting Troubleshooting and Tips guide for some simple demonstrations to help explain things such as this. :slight_smile:

You can find the link in my signature below.

Thank you very much for the reply.

Effectively increasing the Map Resolution Light for the ground, improves the quality of the shadow projected onto this. But why a BSP Cube itself casts the shadow correctly without having risen the value of Light Map Resolution?