Download

BP editor takes a long time to do anything

when I add, take away, open a function, open a macro or open a collapsed node it stops everything for a couple of seconds and I hate this.
how do I fix it?

and an example of how big my BP is.
when I stop talking I accidentally pressed mute (it is the same as the back button on my mouse)

Hi there,

Unfortunately I don’t have an answer for you, but I did notice you have a lot of tasks running. Your icon tray (the bottom right) is pretty full. By comparison, the only things I have running down there are an Nvidea panel, AVG, a VPN, and a Java update waiting to happen. That plus the usual sound controls. I do have other background tasks, such drivers for a wacom tablet and I often have a webpage open at the same time, but it doesn’t look comparable to yours.

Has it always been doing this? Are you low on HD space? Does it only do this in 1 project or are they all the same, including a new blank project? Are you using a laptop? which processor etc?

What are your computer specs?

Most of those are pinned to the taskbar but not actually running.

3770k 3.8GHz - no OC

16 GB 2X8 Ripjaws

XFX 7950 core edition - no OC

the UE4 and the project is running off of an SSD separate from the OS SSD

the tasks are
Google Hangouts
Autodesk app manager
Hotspot shield
Folding at home - this has low priority and stops if pretty much anything else is using the processor
Norton AV
Google drive
sound thingy
connection
windows notifications
another sound thingy
USB thingy

I have collapsed most of the nodes and that has more or less fixed the problem

Hey AlphaSierra216,

Have you tried running the windows performance monitor to see where the problem is originating (ie whether it is the CPU, HD etc)? When that issue occurs in your editor, try to have that open as well (on a separate monitor, or scaled down to fit both on one screen) to see if you are getting a huge spike in CPU usage, or HD read/write. If there is a large spike, also open the windows Task Manager (right click on the taskbar, select task manager, and make sure you are in the Processes tab), and then click on the column bar to sort the programs using the usage % corresponding to the large spike (if it is CPU, click on the CPU % column header, if it was a HD spike then click Disk % etc, as seen in the image below, taken in windows 8 so it may look slightly different) and this will sort all of your programs by the highest percent usage of the device a program is currently using (ones at the top will always be the highest). Then, again in the editor, re-produce the issue and watch for the program using the most resources during the time that your editor hangs, if it is not UE4 using the most, close whatever program is using the most resources, and try again. This will help to narrow down what exactly is causing the issue.

b080ea64c25b710f8fd1689dd001d183c0701a58.png

If there are no large spikes (or only small spikes) occurring at the same time you experience slowdown, possibly try turning off your anti-virus software, then re-open the editor and see if that makes any difference, it is possible the settings are too restrictive, forcing every disk read/write to pass through it first.

And if none of those work, just to test if the GPU is the issue, try turning realtime off in the viewport (click the down arrow, un-check “RealTime”), and again see if that makes a difference, this is less likely in my opinion to be the problem, but it is worth trying.

Let me know if any of those help, or if none help, and/or if you need more info! :slight_smile:

Nothing spikes
the cpu stays at around 20%
the disk jumps from around 0KB to 1000KB - after it settles down from startup
the Ram uses 28%

antivirus changes nothing real-time changes nothing

Hi AlphaSierra216,

Can you make a post about this on the answerhub at http://answers.unrealengine.com so we can track it?

Won and done Adam

https://answers.unrealengine.com/questions/73896/why-is-my-bp-editor-extremely-laggy.html