Borderless window mode broken in 4.6


The FullscreenMode=1 in GameUserSettings.ini display my Win64 dev package game in fullscreen on the main screen (3 screens configuration) where it filled the 3 screens in ue4.5

I workaround with Gamers Window Relocator software so I didn’t spend time to check engine source code.


Hello HydralX,

Would you provide me with your dxdiag as well as some reproducible steps so I can test this issue on my end?

Thank you,


You can create a blank blueprint project with 4.6 or 4.6.1,
-save the entrymap to another name to assign it to the game start level (so we don’t have black screen for unassigned map…).
-package project to Win64
-edit GameUserSettings.ini with

I test it on another hardware configuration (intel graphics and 3 screens) and see the bug (fullscreen instead borderless).

link text
link text

GameUserSettings.ini :


Hey HydralX,

If you wouldn’t mind testing something for me. Would you try and reproduce this issue on the most current version of the engine? I am curious to see if it was addressed in the 4.7 preview 5 build.

If you are not able to reproduce the issue, or just cannot install the newest preview let me know.


The easiest way to test this is to play in stand alone mode and using the console command “setRes (Width)x(Height)wf”.

or in c++

FSystemResolution::RequestResolutionChange((Width), (Height),EWindowMode::WindowedFullscreen);

This work fine in 4.5.1 and broken since 4.6 (I’ve tested this with 4.6.1 and 4.7.2)

Hey guys,

I ran tests on a blank project in 4.5.1 and was not able to get the fullscreen to span across both monitors. I also got other team members to test the issue as well and got the same results as myself.

I was informed that spanning fullscreen across multiple displays is also a Windows feature, so you could check to see if somehow this has been disabled somewhere in Windows.

To be honest, for as long as I have been working with UE4, I have never been able to enable fullscreen and have it span across my multiple monitor set up by default.

Perhaps it has something to do with code? If you have any additional information, even though it seems you guys have given me as much as you can that would be helpful in getting a repro so I can write up a bug report.

If you would like you could also try sending me a project where you know this reproduces.

Thank you,

I’ve tested it in 4.5.1 and the borderless is still working. This is the step to reproduce borderless in 4.5.1

  1. Create a blank project.
  2. Create a GameMode and a HUD blueprint.
  3. Set the world setting to use those mode and HUD.
  4. Add these nodes to the HUD


  1. Play in Stand Alone mode.

BTW I looked up 4.6.0 release notes and there is a line saying :

“Fixed windowed fullscreen modes so that you can specify resolutions less than the native desktop without causing the window to appear incorrectly in the corner of the screen”

[The release notes][2]

This sounds relevant.

Hey Wisawing,

Thank you for the reproducible steps as I was able to successfully see what you are reporting.

With that in mind, and after reviewing the release notes and speaking with some other team members, the fix that was implemented in 4.6 is what is directly affecting the change you are seeing.

It is with this information that what you are experiencing is expected and is not an actual bug and is functioning as intended. The default behavior when running windowed fullscreen mode takes into account the resolution you set and displays that in the windowed version with the option to maximize the window.

The behavior you were seeing in 4.5 was actually not correct which is why it was fixed in a later version. If you have any other questions or concerns about the issue please do not hesitate to ask.

Thank you,

Thanks for the clarification. Since it’s actually a bug, I suppose there isn’t a way to create a borderless game window?

My pleasure. If you are attempting to play borderless, the windows fullscreen command should still display a fullscreen borderless mode based on the resolution you have entered.

If this is not the case, then we have a bug. In fact I just attempted to test the issue you mentioned was fixed in the 4.6 release notes, and it still displays incorrectly.

“Fixed windowed fullscreen modes so that you can specify resolutions less than the native desktop without causing the window to appear incorrectly in the corner of the screen”

There might be some correlation here so I am going to continue to track this issue.


Hey again Wisawing,

So I did some digging and discovered there are a handful of Windowed Fullscreen bugs in plan to be fixed for the release of 4.8.

Once these fixes are implemented, the issues we are seeing should be resolved.