Borderless fullscreen window

Hello. Quick question: is this already implemented? It seems every game / engine has this nowadays and I would really like to see this in UE4 aswell.

I haven’t looked for it so maybe it’s already there, but if it’s not it’s high on my wishlist.

As a multimonitor person (I expect most developers and artists here are as well) I would love to see borderless window support.

Do you mean Full Screen Mode (Shift+F11) and Imersive Mode (F11)


If you set it to Fullscreen Mode it removes your task bar and sutch.
WCode

I mean an option in the code that allows you to create games where you have fullscreen borderless as a display method alongside with normal fullscreen. Even if resources are well managed in fullscreen mode you still have a hiccup when tabbing out of the game. This is why I love borderless fullscreen so much because you can instantly jump in and out of the game without any hang up or problems.

Bump…

So what you are really asking for is a borderless windowed mode specifically which snaps to the current resolution.

It’s already implemented. I’ve used it in my gamejam game and it works nicely.
You have to modify GameUserSettings, basically to set FullscreenMode to 1.
How to get GameUserSettings: A new, community-hosted Unreal Engine Wiki - Announcements and Releases - Unreal Engine Forums
API: UGameUserSettings | Unreal Engine Documentation

Glad to hear that ze0rb! Thanks for that!
@HenrikRyosa: exactly. I’m surprised that this isn’t commonly understood, basically every game you play that is less than three years old has this option in the video settings…

I love borderless window. For those people that don’t understand the difference between borderless and full screen, alt+tab or hitting the start menu button works a lot better in borderless window. In fullscreen there are massive delays flickering monitors, etc…

Exactly this!

Btw I tried setting “fullscreen 1” in Unreal Tournament, I believe in UT it is just a boolean for now, it doesn’t know modes, and just changes between normal windowed mode and fullscreen :(((

Choose desktop resolution and turn off fullscreen. It makes borderless fullscreen mode, at least for me

If I do that I just have fullscreen again. You can tell by using alt tab and seeing the flickering. I guess I’ll just wait until they officially put it in - can’t be long now…

I don’t have any flickering and it is definitely borderless fullscreen :slight_smile: Maybe your customized settings in ini file are overriding settings from game itself or something like this?
Try this:

  • Turn on fullscreen
  • Turn off fullscreen
  • Change resolution to something low like 1024x768 and you will see windowed screen
  • Set resolution to desktop resolution. Still windowed. Keep fullscreen mode OFF
  • Restart game