Bones with physics "lagging behind" at high speeds

I’m having this annoying problem with skeletal mesh bone locations not updating fast enough when the skeletal mesh is moving very fast.

So I have created a vehicle and now I’m adding a driver. I want the driver’s head to have physics so the head would be rotating from side to side at sharp turns and forwards/backwards under acceleration.
It’s working fine but at high speeds the location of the head start to lag behind.

The skeletal mesh(driver) is attached to the vehicle mesh and the head bone has physics enabled.

I have tried changing the Tick Group of the Driver Blueprint and Vehicle Blueprint to Post Physics and Post Update Work, but nothing seems to help.
Also the Linear Limits are locked from the bone constraints, so that’s not the issue.
Does anyone know how to fix this?

do this in a POST physics timeline.

Thanks for the answer!

Sorry if I was unclear but I have tried that. The Driver Skeletal Mesh Component Tick Group is set to Post Physics and I have also tried other options like Post Update Work.
I also tried to set Post Physics in the whole VehicleBP settings and also in the VehicleMesh where the Driver Component is attached to.

Am I doing something wrong?

I couldn’t find a way to change the Tick Group of the Animation Blueprint? So I guess that’s not possible/necessary.

I found a workaround that fixes my problem.

To me it seems that the Tick Group setting of the Blueprint doesn’t inherit to Children for some reason.

So I’ve set the Blueprint Tick Group to Post Physics.
At event BeginPlay I detach the Driver Skeletal Mesh Component from the Vehicle mesh.
Then at every Tick I Set the Driver’s World Transform to Vehicle mesh location.

This works but now I have that extra Set World Transform firing at every tick. So if anyone knows a better solution, I would like to hear it.