Download

Bones imported incorrectly

Hi!
It’s the first time I’ve tried to import Skeletal Mesh into UE4. It’s a very simple model, I only need to import it as a skeletal mesh because I want to use APEX cloth on it.
It looks OK in 3ds Max:


But messed up in UE4:

I could fix it by moving it to 0,0,0, so it works now. But cloth didn’t work as I got the 2 piece merged. If I detach the smaller part and make it separately, it works, but collision doesn’t work.
cd023522aa465119b053a622aed9d369f386060e.jpeg

It looks correct to me, what is wrong?

As you can see on my last image, the smaller, decorative cloth piece is inside the larger flag cloth. I want them to collide. In 3ds Max, they doesn’t collide either if I use them as separated objects, but it works if I merge them. BUT inside UE4, it looks messed up.

This is how it looks inside Max (with PhysX’s viewer):
10e4962f26989d45712ec74d8401c92c9d853b00.jpeg

Inside UE4:
66670930e19e618bdb9509a0ccb09986dc06d917.jpeg

Layered cloth is difficult to do so I would think you would need to have those as separate objects for them to work right. And make sure that the default pose doesn’t have them intersecting.

On separate do you mean separate FBX files?