Bone Orientation/Movement Issues When Importing Animation From Blender

I am experiencing a strange issue with a few of the bones when importing an animated skeleton from Blender v2.82a into Unreal Engine 4.26.1. Some of the bones seem to be oriented incorrectly after importing.

Here is the animation playback while in Blender:

And here is the animation playback in UE4:

Everything looks correct except for the orientation and movement of the neck bone, and I’m really not sure why. I tried a few different FBX export settings in Blender and import settings in Unreal, but neither seemed to solve the issue.

Here are my import/export settings for reference:

I know importing from Blender can be pretty wonky, but I haven’t seen this specific issue covered on the forums. So, I apologize if I missed another thread containing the answer.

If anyone has a solution to this, I’d greatly appreciate it!

my own workflow:

  1. export skeletal mesh without animation first, mesh+armature and disable bake animation. ( and set in rest position)
  2. then export only the animation, armature and enable bake animation. (in pose position)
    i usually unchecked add leaf bones as well.

@Arodi007 Thanks for the suggestion! I just tried exporting exactly how you suggested, but unfortunately, its the same issue. The neck bone still has extra movement/incorrect orientation.

then it most likely an issue in blender, i seen some people following some advanced tuto on animation causing ue4 to read it incorrectly.
or just a bug on that blender version.
worse case would be a cache issue that happen to me and got similar issue.
you could upload your blender file here so that we try it on our end.

It’s not strange, it’s a blender bug that the blender people don’t want to address.

Remove all stretching from all bones. They’ll stop rotating around randomly.

Obviously this involves some pretty heavy rig editing.

You can also try to make the n^t bug report on it.
It seems like they learned to ignore them from Epic.

1 Like