Download

Body mesh pulled off from rest of rig - why?

Hi there,

so I have a problem where the body mesh of a character gets pulled off from the rest of the rig during a couple of animations (it doesn’t do this with other animations). I have no idea why - does anyone know?

I’ve tried re-rigging the character again using mixamo and it still produces the same result.

Is there any warning on the output when importing ?
check if it scaling is 1 (ctrl+A) all transform if u using blender and check if it root is properly connected.
You need to give us more info on the workflow of your armature as well. (set up for export etc…)

this is the warning i get when i import the skelemesh


this is what are my export settings from maya

and here are my import settings

try to fix these warning first so to narrow the issue.
usually unchecking add leaf bones in blender fix that but you will have to google it since it been years i havent touched 3ds max/maya.
other than that the import setting, T0 as ref pose and import animation should be checked by default:

How does that make any sense when you are importing a model?
The animation file is a completely separate thing form the mesh.
Definitely doesn’t need to be checked wen importing meshes or mesh parts.

@1ncog
The Maya settings for the FBX file format are probably off?
Double check the docs on which version to use.

If the problem persists, I would think the issue is the model and the skeleton not being properly associated (hence the weight paint missing warnings)

Hey, thanks guys. I tried following your advice but it didn’t change anything, so I cleaned the model of everything attached to it like skin weights, morphs, constraints and basically rigged it from scratch… It works fine now.

1 Like