Bodies of the Physics Asset don't collide with each other

Hello dear forum!
As stated in the title I’m having issues with the collisions of the bodies of the Physics Asset. I’ve a humanoid rig and I set up bodies and locational and rotational constraints and it collides with the ground and other physical objects in the game world, but the bodies don’t collide with themselves. How would I set up a system where the bodies of the Physics Asset collide with themselves? My plan is creating a trench coat which consists of 3 bone chains and each bone having a box collider and I want them to interact with the legs of my character. Any suggestions are welcome!

Have a nice day!

Why not simulate clothing for the trench coat? You should check the content examples…

simulated clothing is bugging out a lot for me. Like getting stuck in the leg, clipping through bodyparts …

2 Likes

and even though … even my legs aren’t colliding with each other properly Screen capture - 801a43022c89c1854ca3bccea1bfc442 - Gyazo

They made a lot of changes and I don’t think the docs are currently up to date. If you haven’t seen this one yet, it gives you some info on what’s different.

As far as the issue, It’s something I’m also experiencing - on top of other issues specifically with PHAT (I can’t even drag the limbs in the current project right now O_o)
I believe my issue particularly is wrong collision definitions. I created the PHAT model i was looking at in a rush…

So I found the solution and it’s stupidly easy … you basically select all of your bodies and on the top bar you press “enable collisions”. Somehow my collisions weren’t enabled when I created the bodies. All working now!

4 Likes

Doesn’t work

2 Likes

Hey guys, if you are using UE5 5.0.1, these steps worked for me:

  1. Go to your Character Blueprint
  2. Select the Character Mesh
  3. Under Collision, set ‘Collision Presets’ to ‘Custom’, and set ‘Collision Enabled’ to 'Collision Enabled (Query and Physics).
  4. Just below, set ‘Object Type’ to ‘PhysicsBody’.

Those steps correctly applied the Physics Body and all the self-collision configuration that I have done.

2 Likes

Here is the solution:
In Physics Asset First select all of your bodies ,right click ->Collision ->Enable Collision All .You simulate now probably you will find your character fly around .Because they maybe overlaped with each other before, then you need to select bones which are next to each other.Select each other or three or four,then again right click->Collision->Disable Collision. Do this to all bones,then it will work.

5 Likes