Blutility Minus Scale Issue

UE4 Blutility, Giving An Static Mesh an -Scale X or/and Y or/and Z, results in weird behavor of Model Showing(The Upper Image is when i did one of the a b c steps, the down image shows the models( Yellow )( This happens to a variety of difrent models ),bot have the same Position/Scales etc.

, it can be solved in Editor with:

a) Sometimes using the Play/Stop Button

b) When changing the Relative Scale Into Absolute Scale

c) Sometimes when altering the Scale Values or pressing “Enter” with them

**PS.**Also an Tool or the posibility to add (Drop And Drag “like”) multiply Static Meshes into Array or the posbility to show an Folder or Pointer wich could be in an Folder to say please add all this meshes to This Static Meshes Array. To Take it Short: Some Way to Control Assets in a Larger Way.

Cheers Again

Hello ,

I ran a few tests on our end. I was unable to reproduce this issue on our end. I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps (that include any small steps that may have been missed in your original post) to reproduce this issue on our end?
  3. Could you provides screen shots of any settings/blueprints that may be involved?
  4. Does this happen with default assets in the editor or does this only occur with assets (static meshes) that you have created?

Hello Sir,

So First sorry for my late reply,

  1. I was not able
  2. I Mainly use ( beneath the some math i Do From Getting Scales/Location/ETC ), the set World Scale, set Location & Rotation on static Mesh Component, in Editor( Blutility )
  3. I send You U some ScreenShots, but what you can’t see i describe here:
    x) I Use One Type OF Blueprint (“Example_BP”) and just replaces the root Static Mesh Comp for them
    y) The static mesh was In the procedure of placing : Attached( Also Comp To Comp of Socket ) and than Detached( Keep World )
    z) Also I did you wrong, it appears that it’s not an Totaly Scale Issue, ( But still it might be that the parrent before was Scaled Negativly ). On the Newest Picture were the same Issue Happend to an Starter Content Mesh, Shows positive scale but still Error with "Inverted Faces ". Can be solved with steps mentioned before.
    zz)My Procudure is not Very Very Fastest, it may takes some milisseconds to Count the math an place everything. Mayby that’s an issue in Blutility ?
  4. Yes, also described in " 3. z)

PS. Do you know any console CMD that refresh The Rendering in Editor ?


Are you using any unofficial plugins? If so, could you remove them and let me know if this issue still occurs?

I have my Own Plugin wich is in the Content Folder. But I cannot remove it and still do this Build afterwards. It is relativly simple, mostly math. and ustruct’s. But i have Victory Plugin wich is also unnoficial. Beyond that official substance and Save and Log Profiler . Do you know mayby some commands wich emulate the refreshning the Mesh Comp. insde Editor ?

In order to assist you further, we will need to rule out the potential cause being the plugins that you are using. I will need you to reproduce this issue without any of the plugins mentioned above. If the issue no longer occurs after removing the plugins you will need to speak with the creators of the plugins for further assistance as we do not provide support for unofficial plugins.

Eureka, the problem of the “Inverted Faces” Was caused due the use of “Moveable” Setting with the Static Mesh Component. After Setting it “Static” it started to work like it should.

I am happy hear that you were able to resolve your issue. I will be converting your last comment to an answer. If the issue returns please feel free to reopen this issue with an additional information you may have and I will be happy to help.

Make it a great day