Blueprints won't allow other blueprints with same input to work.

Hello. I have run into a problem when working on blueprints for my level. I have a door class blueprint that plays a timeline when I am a box collision and pressing a button. When I place multiple doors in my scene and play, I’ll open the first door and it’ll work fine but when I try to open the other door, it won’t work. Here is what the actor looks like.

Here is what the script looks like.

Any insight into what is going on is greatly appreciated. Thanks.

You disable DoorActor inputs when you exit the trigger?

I got rid of the key inputs and the branch and it works just fine. I just need to find a way to get the input nodes in there without messing up any other of the same actors placed in the scene.

OnComponentBeginOverlap->Enable Inputs->…
OnComponentEndOverlap->Disable Inputs->…

I don’t disable the input when I leave the trigger. I had a branch with a variable called InTrigger that would tell me if the player is in the trigger and a key press execution node to so that.

i know , if you don’t want that input priority issue you have to use enable/disable inputs
ps. you are not disabling player input but for the door that you left

Use The Gate Function

The open and close will allow you to use the (Interact Key) without messing with that specific object For example if you look at my picture this opens and closes a door, using the Move component to function. it works like this the player walks into the box trigger (Gate Opens) player presses E then it fires into flipflop A first which opens the door and it moves the door and if player presses E again while stangin in the box trigger the door will close again. Gate helps make it so that this function will only work if the player is standing in the Box Trigger

Not sure if this will help you… and it sounds like the previous post is the best way… but for future reference i had a similar problem (nothing to do with doors) but trying to use the same input action in the HUD blueprint as well as the character one.

When you click on the input, in the top right it says something like “consume this input”

I unchecked that in both spots and it allowed me to use it in both contexts after that.

Thank you so much! :slight_smile: I saw that Consume Input was checked and when I unchecked it, everything started working again. Thank you all for your great advice.

god bless you my friend, it´s work like a charm here !