Download

Blueprints stop working, NO ERRORS, fixes itself after some time

My project was going great untill 2 days ago Blueprints started misbehaving.
First it was my menu that for some reason stopped detecting mouse clicks after it worked fine for 3 weeks …

Now another function with a for each loop stopped working after it worked fine.
And spawn actor from class is not working too. JUST WDF???

I do not get errors and the same code works in other projects.

I tried cloning, migrating, engine reinstall nothing fixes it, the problem must be in my project but I don’t know how to fix it .

This guy seems to have the same issue with his for loop which mysteriously starts working again

[FONT=Arial Black]My Answerhub post

You know there was a lot of black magic spam threads here, so i guess someone from “other engine” community saw those and contacted them and they did some black magic voodoo stuff on our Unreal Engine. Maybe their power is now gone and that fixed your Blueprint problem.

Yeah I saw these useful topics…

Update: It seem that [load game from slot] > [cast to ***]> [get struct] > [break struct] does not work correctly because I replaced the struct with just normal values and now the problems are gone. (hope you can imagine the BP)(BP struct)

This still doesn’t explain why for 8 hours the [on released] event for one just one box component was not working and then fixed itself