Blueprints and menus not functioning after win10 update

I’m not sure that this isn’t totally idiosyncratic to my machine.

I was working on a project based on 4.13.2 today when windows 10 popped up an update window. Given the recent hacks, I thought it prudent to stop working to let the update run its course. After 4 hours, the update completed. When the machine came back up, I found that I could no longer script using blueprints in that same project.

I could drag out a wire (or noodle or whatever ue4 calls them), but the new node won’t pop up that list of possible nodes. The menu itself doesn’t appear. The wire just terminates as if it were connected to a node (but it isn’t connected to anything). The menu itself doesn’t appear.

I can connect between existing nodes, and drag variables into the blueprints area and have them to the get/set thing with ctrl and alt. I just can’t place new nodes, meaning my scripting is dead in the water. I am an experienced c++ programmer, but I use blueprints for the convenience and for rapid prototyping. I didn’t try opening visual studio to see whether that worked properly or not.

I couldn’t get the ‘File’ or ‘help’ or any of the other menus to work either, regardless of which ue4 editor window I had open.

So, I’m guessing it’s something to do with menus.

I restarted twice, then tried old versions of the project from 4.12 and 4.11. neither worked.

I tried creating new blank projects in 4.15, 4.14, and 4.13

4.15 worked fine, but the computer asked me to allow the ue4 editor to access public and private networks through the firewall.

4.14 worked fine, but the computer asked me to allow the ue4 editor to access public and private networks through the firewall.

4.13 allowed me to create the project, did not ask me to permit the editor to access through the firewall, and I could not script in blueprints or open menus, reproducing the error in my project.

I hypothesized that the firewall settings might be the culprit, hunted down the firewall in the windows 10 settings, and allowed unreal editor 4.13 to have access to public and private networks through the firewall.

The error persisted, so unless the firewall settings just didn’t save right (It’s possible; it’s happened to me before), that’s probably not the problem. Or maybe I didn’t shutdown and restart.

I have since updated my project to 4.15, so I can still make progress. I just have to wait for the shaders to compile. Meh. It was probably time for an update anyway.

I just thought I’d report it in case others have seen similar problems. It was working perfectly fine up until the win 10 update, and then not after, so I think I know who to blame…

Hello enakops,

It sounds like you were having the issue that can be found at the link below. I am glad that you were able to work around the issue. Thank you for the additional information.

Link: Microsoft Creators Update breaking UE 4.13 - Programming & Scripting - Epic Developer Community Forums

Make it a great day