BlueprintCallable very strange issues on mobile

Firstly, everything works as expected in the editor and mobile preview but not on my device.

Galaxy S5, Android 4.4.2

UE4 version 4.6.1

I have no idea what’s causing it, it’s very bizarre. I tried the same in an empty project and it seems to work. I just can’t figure out what’s causing this strange behavior in my project. I should add that I discovered the problem not by attempting this simple method, but one where I was returning custom object. This method below was purely for testing. It also doesn’t work with objects or float values.

I have this method in C++

 UFUNCTION(BlueprintCallable, Category = ElementalAI)
 FVector VectorCheck();
FVector AElementalCharacter::VectorCheck()
	FVector v = FVector(100, 100, 100);
	UE_LOG(LogElemental, Log, TEXT("V: "), *v.ToString());
	return v;

This is what happens if I call that method from BP on my Character (or any other custom class/blueprint, I’ve tried many)…

From OnPossessed (or BeginPlay). It does nothing. No result from the Print String and Nothing logged from the code (checking the log file on device and using logcat). Game runs as if it was never there.

And now the weird bit. When I attach it to the end of my existing blueprint nodes, which have worked flawlessly for months. It causes the node before it to run in an infinite loop (in the case of the picture below: “Give Weapon”, also moved it up the chain with the same result). Still no output from the Print String or from the code. Game cant run due to infinite loop. I have to force quit on the device.

I’ve attached the output of LogCat and the Log file. link text [link text][3]

Sort of fixed…
I created a new project, copied all my code and migrated all my assets from the original project and it now work on my device.

Still no idea what caused the problem though.

Hey DannRees-

Have you had this error happen since creating a new project and copying everything over? It sounds as though the blueprint became corrupted and recreating it (along with the project) fixed the issue. If you have this problem come up again in the future feel free to reopen this post with any additional information you have.