Download

Blueprint Wire Connections are Lost on Restart

It seems some data wires’ connections are lost when restarting the editor. Only happens with data wires, not execution wires; however it makes it pretty unusable. In order to start playing my game, I have to reconnect about 20 or so lost connections across many classes whenever I restart the editor. Once those connections are reestablished everything works fine though.

This appears to be a problem experienced by quite a few others: Blueprint pin disconnects after restarting the editor - UE4 AnswerHub

I am posting this here because it might be something I’m doing–perhaps my classes are too complicated, or I am doing references wrong (it seems to be most common around getting data from references (i.e. Game->MyPlayerController))

By the way, I have had this happen in 4.12.5, 4.13.2, and 4.14.

Any help is greatly appreciated, thank you.

Im having similar problem (probably everyone) when i change e.g. class for spawning actor, return value (reference) is disconnected. Try to describe repro setup, i will try to do it on my pc… i had one big sound problem and even with repro setup, i was able to repro it only on my computer… ppl from ue staff wasnt able to repro it.

People on the answer hub also had trouble getting Epic to be able to reproduce it. It’s a hard thing to pinpoint, for in a brand new project it works fine up until a certain breaking point. What that breaking point is, I have no idea. Once it’s broken though, it appears to be broken forever.

I had a simillar issue when I was getting a UMG object(a wrap box to be exact). What I did was go to the UMG, and rename the object name, then went back to the blueprint and recreated the connection and seemed to fix my problem.

I tried renaming everything, even rebuilding my blueprints from scratch in a new project. Nothing fixes this issue so far–I suppose I have to use C++.

As a general rule, when there is weird behavior that appears to be unique to you…create a new blank project and migrate your project into a new one. You’d be surprised how many weird anomaly’s that can clear up. I do it regularly every couple months. I swear projects just erode naturally over time.

Hi…i am a new user here. In my case i faced the issue with UMG object. I tried this rename the object name, then went back to the blueprint and recreated the connection. But still i am facing the issue. Can you please let me know what i should do?

one-stop pcb

I tried renaming and re-engineered the blueprint from a new beginning, the effect is not good, I don’t know why.
PCB SERVICE