Blueprint window blank when trying to open game mode blueprint

When I try and open up my game mode blueprint class, I am getting a blank screen.

I’d like to post a screenshot, but when I click the image button and choose the screenshot .png file I made, I get the error message “no such upload”. So both Unreal and the Unreal answer website are giving me problems right now. I will say that it looks the same as the blank screen posted in the link below to another question.

In terms of trying to fix the blank screen, I tried deleting intermediate, saved, and config files as recommended in this thread:

But this did not solve the problem.

As a workaround, I tried duplicating the class, to see if I could open and edit the duplicate. It gave me a blank screen as well.

Has anyone else had this problem? Is there a solution, or will I have to recreate that entire game mode blueprint from memory?

Thank You in advance.

Hi jojo212,

  • Does this occur in a clean, blank project with no additional content or is it limited to one project/blueprint?
  • What steps did you take before this occurred?
  • Is the window completely black/blank or is there any text present on the screen?
  • Have you run a verify on your engine? Go to your Launcher>Library>Engine Version context menu and press “Verify” to ensure you have no damaged files.
  • If the above did not help, try running a “fix up redirectors” in your content browser by pressing RMB on your content folder>fix up redirectors.

Hi ,

This is occurring in a project that already has content, but the issue is only occurring with one blueprint.

Before this occurred I was creating other blueprints for game objects.

The window is completely blank, except for Compile, Save, and Find in CB at the top.

I have verified the engine, it did not fix the issue.

I have run “fix up redirectors”, it has not fixed the issue.

Here is a screenshot:


Let me know if there is anything else I should try.

Hey, I just opted to re-create the blueprint from scratch since it wasn’t too complicated. I kept a copy of the original blueprint causing the problem - would you like to keep this ticket open to try and fix the issue in case it is a future problem? I could see this bug potentially undoing many hours of hard work, and I’d be happy to cooperate if you would like to get to the bottom of it.

The screenshot actually helps immensely. If this occurs again, you should be able to re-open windows by going to Window>Reset Layout. It will restart the editor but all windows should be re-opened. If they are not, you can manually open the windows needed by going to the Window tab and finding the specific ones you are looking for.