Download

Blueprint root component static mesh won't resize?

I’ve made a blueprint and added a static mesh as the root component. I’ve chosen a static mesh that I imported, but it’s very small. When I try to use the size transform values on the root component nothing happens. In fact all of the transforms on the root component seem to do nothing. How can I make the root static mesh bigger?

I don’t think you’ll be able to edit the root component. I’ve seen it suggested before to make the root component an arrow component so you can visualize the orientation of the blueprint better, then just attach other components you need to that.

Hmm okay I appreciate the reply. I might have a different issue then, and I might make a separate thread for that. Maybe you’d have thoughts on this:

I currently have a simple sphere component as the root, with the static mesh attached beneath it. This is a pawn blueprint. The sphere has collision detection enabled and it works as expected. I’d like to use the static mesh as the collision detector instead, so I turn off collision for the sphere and turn it on for the static mesh, but collisions aren’t registering for the static mesh, it floats through everything. I have made sure that the mesh itself has a collision hull calculated and saved.

The original question was prompted by the idea of just making the static mesh the root instead of the sphere, but I’m a bit stuck if neither of these options work. Also it doesn’t help that turning off the collision for the ball screws up the force/torque based movement system I’ve got in C++, but I was hoping if I could get collision working for the static mesh I’d just apply the forces to the mesh as well to keep the movement going. But the mesh is either too small and can’t be resized (if it’s the root) or doesn’t actually collide with anything despite collision being on (when below the root).

I assume you set the exact collision properties to the mesh as the sphere, and have the proper collision on the meshes you want to collide with in level? I tested this out, and having collision to “Block All” on the mesh I was to hit against in the level, it blocked the capsule component and the mesh when the capsule component’s collision was set to NoCollision. If you’ve done all of these things and it still isn’t working, I would say there may be a problem with the mesh’s “collision hull,” but I don’t have any experience with that part of the development process.