Blueprint - OnOverlap - Hide Player?

Hi, I tried creating an overlap event in Blueprint in which once the player overlaps the trigger; It hides the player from view until a Matinee cutscene is over, which then it will unhide the player and the player camera. I tried using hide actor and destroy actor on ALL the components of my player (Third person example) but it’s not hiding or removing my player from the game.

Is this a bug or am I doing this the wrong way?

Firstly make sure that your OnActorOverlap event is triggering correctly (perhaps use a breakpoint or a Print String node to verify), and that your collision properties for both your Actor and your Trigger are set correctly.

You can use the Toggle Visibility node to hide your actor from the scene. You can hide the whole actor instead of hiding individual components by setting your player as the target input (self, if working on the player’s blueprint).

Thanks works great. Thanks. Do you by chance know how to change the player’s location while the matinee is playing, would the player still stay invisible?

Yes. While the player is hidden, he still exists in the game world. I also believe he still collides with objects etc. because he is only hidden from view, not out of existence or destroyed.

There’s a variety of ways to change player location, but if you just want a simple “be at this new location now”, you can use the “Set World Location” node, with your player actor as the target, and a vector for the new location.

How can i do it gives me this error?

Your target pin is empty. Yyou need the “Toggle Visiblity” node which isn’t for a secene component and is for the actor in general.

Bumping for help

Please don’t bump A) a comment, B) Something you posted 10 minutes ago and C) something that has already been answered for you.