Blueprint not showing

As you can see from the image. The blueprint is not showing it’s content. In fact, it just loads up a gray screen. I am not able to get into the blueprint at all. While the level blueprint loads just fine.

This is a nasty issue since I’m working on my final school project and would like to be able to work in blueprints.
This happened right after I got the Game Analytics plugin to work. But no change if I remove the plugin and so on.

Any suggestions?

I have reinstalled the engine with no luck. Cloned the project and still no luck. I have tried to make a new BP with no change. Even if I make a new project, the issue is still the same. I have also tried to delete the Intermediate and Save folder in case there where something wrong there. But still no change.

I have opened different projects using 4.13, and that works just fine. This is an issue related to 4.14.3.

I have already tested that as well. Just forgot to type it in the initial post.
I try to uncheck them and recheck them. But they just don’t want to be unchecked in the first place. :frowning:

Click on the Window tab at the top of the BP and make sure you have all the appropriate tabs checked for display

124989-windowtab.png

Once you have all of those checked you should be back to normal, you can reopen the Event Graph and Construction Script by double-clicking them in the My Blueprint tab.

124990-mybptab.png

Oh hmm ok, try clicking reset layout, have you also tried restarting the editor? You can’t technically uncheck them, I assumed that somehow you accidentally closed all of them (by clicking the X in the corners of each) or a glitch closed them for you. Is that the only BP to do that?

Edit: just noticed the screenshot is a different BP from the original posted above, disregard that part.

1 Like

Reset layout does not work. Been trying that as well. :frowning:
I also had a clone of my project with stable content that I haven’t opened in a few days. Even that has the same issue.

EDIT:
I do not see any pattern of what type of BPs there is an issue with.

Yes, I have tried that as well, new projects using the same engine version has the same issue. Even after I reinstalled the engine.

Reset to Default had no effect.
And no, I have not made any changes to my preferences at all.

Do any other projects have this issue? Have you tried creating a new project from one of the templates or a blank project to test it?

Ok, go into your Editor Preferences and then down to the Content Editors section and then Blueprint Editor, in the top corner you should see an option to Reset to Defaults. Click that and restart the editor, let me know if that has any effect. Did you make any chances to your preferences prior to this issue?

Ok, Then it is being stored in your ini file…hang on a sec I need to dig into the folders to see which one it is for sure.

Ok go into your user app data folder (Open explorer and in the location bar at the top type this without the quotes: “%appdata%”) and then go into Local\UnrealEngine\4.14\Saved\Config\Windows in that folder you should see EditorLayout.ini, open it in notepad and see if “TabState” for each “TabId” says “ClosedTab” or upload a copy and I can check for you. This is the file that stores your tab layout when you exit the editor.

1 Like

I found the file, and the TabState. I was also able to change some of them, like MyBlueprint to ClosedTab. This did make those I changed to be unchecked in the Window menu. But when I checked them in the menu, nothing happened.

I have now fixed this issue simply by renaming EditorLayout.ini to EditorLayout_.ini. This, as I had hoped for, forced the engine to make a new one.

I now have access to all the blueprint content again.

Thank you Black Phoenyx for helping me out. :slight_smile:

1 Like

For me it fixed removing %localappdata%\UnrealEngine*

This worked for me - thanks.

For UE 5 → Window → Load Layout → Default Editor Layout