Download

Blueprint nodes, is it supposed to act like that ?

I’m in my my custom Controller blueprint, and trying to get the “Get actor rotation” from the “Get Controlled Pawn” node…

1.PNG

After drawing a line from the “Get Controlled Pawn” node, it gives my a box which i can chose what i want to draw from it,so i type in the search box : " get rotation " and it gives me two options .

  1. Get control rotation .
  2. Get actor rotation .

2.png

When i ever i chose the “Get actor rotation” option, it gives me a " Get Control Rotation " node which is different from the " Get Control Rotation " node that i can chose from that options box .
It has “object ‘Controller’ target” input, and cant be connected to the node i just tried to draw this node from… ( yeah what?.. ) .

op1.PNG

op2.PNG

Is it a bug ?

Whenever you wanna link two pins, they need to be from the same type, or at least the input should be a parent of the output. In this case neither is true, you’re trying to link an output pin of type Pawn, to an input pin of type Controller.

This is i already know, they question is : why this is giving me this node when i chose " get actor location " ?

It’s not, you’re not searching for location but rotation.

Besides, context sensitivity isn’t always 100% correct, mainly because it is still acting based on the keywords; which means you can still get a function which can be used but isn’t there, and vice versa, there are sometimes functions that you “can” use, but are not listed in the context sensitive menu.

I just tried this with the latest code, and both options it gave me connected to the pawn fine! Maybe a bug was fixed recently?

get_rot.JPG