Blueprint Multiplayer - Steam Session Visibility

So I have followed the multiplayer blueprint tutorial for Unreal and Steam, I can see the session on my laptop from my desktop. However my co-workers (I’m in US they are in Europe) cannot see my server. I read some info about “Presence” being some region locking or what not, but I have no idea how to change this. Or if I missed some other step to make the servers visible. We are not using the testing steam appID, we have our own already.



I can’t find exactly where I read it but the steamworks Api is region locked. So nothing is setup wrong but it’s not giving the session for the find a server because the difference in region. You should still be able to direct connect via console however.

Hello Dear All,

Year 2018 still we have same problem, im dev. from Berlin and sending to my brother from Istanbul and cant see each others server but can see region servers from other friends, according to my deeply research i just reached that info from Michael Allar : ‘PLEASE NOTE: By default, Steam sessions are created using ‘Steam Presence’, what this means is that instead of using Steam’s master server list for global server searching, Steam will only return sessions within your Steam region and sometimes sessions related to the people on your friends list. If you enable Steam and are unable to see your buddy’s server that happens to be on the other side of Earth, it is not an issue with your configuration but how Epic handles Steam sessions. To correct this, please refer to my GenericPlatformTools plugin. (At the time of this writing, GenericPlatformToolsdocumentation does not exist.)

There is no tool yet but still trying to figure out that issue, if anyone have clue please share with us ?

Thank you…

Here we go unf… believable, after countless hours that guy @jestersheepy save my ■■■, thank you very much man…


1 Like

Thanks for coming back to post the answer ^^