Download

Blueprint Multiplayer: Lobby Game Mode: LobbyPc Not Working

Hello,

The unreal Blueprint Multiplayer video series have been awesome. I am on video 15 Blueprint Multiplayer: Lobby Game Mode and my lobby game menu will not show when i join or host a game. I have made a video to demo where the problem is occurring in the game.

Muhammad Ibrahim6 days ago said: In LobbyPC’s EventGraph the last node in SetupLobbyMenu event, Set Input Game Mode and UI is “deprecated” in UE 4.16. The tutorial is using the 4.11 something version of the node. So when using the 4.16 version of the node the lobby menu does not show in game. Is there a fix for it?

I can not find anywhere were it says the blueprint has been or is deprecated
Capture.GIF
this is located in the LobbyPc under “setup and display the lobby menu”

I dont know why my lobby menu is not showing? if anyone has any ideas that would be helpful.

Thanks,

TheBigOso

Breakpoints and things like print string are your friend, they will help you know where execution is stopping. Something being deprecated means they will get rid of it in the next engine version, as they are replacing it with something else, but shouldn’t cause any problems other than the node displaying a warning on it. Since that node looks fine, it doesn’t look like it is deprecated. All the ‘Set Input Mode Game and UI’ node does it set the input focus to whatever you are setting it to. This node being broken shouldn’t change anything with how you view the widget, just how you interact with it once it is on the screen. Input focus is just which object will receive your input (clicks, button presses, etc.). I imagine that entire event call is not going through for whatever reason, which might explain the widget not showing up.

Another thing you can do to help debug is actually watch the execution flow in the Blueprint graph (Only in play in editor, not standalone or packaged game). Once you play the game, you can go into the blueprint, and set the debug filter for whoever or whatever object/client you want to watch the execution for, and then you can see maybe what went wrong.

@TheBigOso

you’re correct in that the [SetInputModeGameAndUI] node has been deprecated but the one you are using is the correct one or updated version.
(the old one would have a yellow warning on it about it’s deprecation & would show in red as well)
but that node is for setting focus for the mouse so you can use it a specific way, it shouldn’t have any relevance whether your menu shows or not. you have done that with the [AddToViewport] node already.

but that tutorial is old & hasn’t been update or fixed. I’ve watched that video series before & it’s a long and detailed tutorial which requires a ‘specific’ setup so if anything is not hooked up right or not set right then there would be problems.

I did notice in the comments for that specific one (15) someone mentioned something about the game mode - if you created a new game mode then make sure you have it set in your world settings (settings can be found in edit tab at top or top of viewport).
but that’s just one of the things you can check. after watching a bit of this series there’s a lot that can go wrong & if it’s not something simple that you can do like with checking the game mode I mentioned then you would have to do like Jamendxman3 said above & trace and/or debug till you found what the issue is.

best thing I can do for ya other than the advice above is to wish ya luck :wink:

im a sql programmer for a data analyst company and i use the print screen trick all the time. I could never find the log to find out where things are breaking. Thank you for the widget explanation that helps.

Another thank you for the debug execution flow. I was looking for a log file in a console screen but the break point start and stop is a gui version of that.

if anyone wants to know how to work the debug execution flow here is a great video.

https://www.youtube.com/watch?v=pF-e3-HAwyE

Im going to now go and find the point where my program is breaking and fix it.

Thanks for everything,

Oso

You can go to Window -> Developer Tools -> Output Log, to display a log for the editor. I want to also mention that you can do a stack trace. I’m not sure if you can see logs for Standalone game from the editor, but if you can, it would probably be in the Project -> Saved -> Logs folder. I see @ 6:30 in your video, you are getting a random element from an array. I can’t remember if they added a random element function, but you can just do Random Integer, which will get a random element from 0 to (Max - 1), which would accomplish the same thing, and take up less space :slight_smile:

thank you Jamendxman3 and ayretek for the great tips the debugging worked great. Output log is a must have.

oso

For me it was problem that LobbyGameMode had wrong playercontroller setup on LobbyMap. ayretek said “if you created a new game mode then make sure you have it set in your world settings”.
Thanks man!

Did anyone figure this out ?

still no solution?

Just confirming that Ayretek’s suggestion of going to the Lobby Map and changing the player controller and the game mode override was what fixed my Lobby Menu not showing up. Also note that I am using version 4.20.2