Blueprint loses connection every time editor restarts

I have this Blueprint and the marked connection gets lost every single time I restart the editor.
How can I solve this issue?

Ok, found the cause:
Renaming the function in the game state from “GetLivingGoblinsCount” to “Getlivinggoblinscount” solved the issue.

There seems to be a problem with the automatic “readability” feature. Camel case function name gets modified to have spaces in between - this seems to be very error prone.

I’m going to avoid camel case / spaces / underscores in Blueprints from now on.

Oh, I’m using 4.5.1 by the way :slight_smile:

With the information above I was also able to track down an annoying AI error in a Behaviour Tree.
My creatures didn’t move to their random chosen location. Renaming the BT Service from “BTS_CallFindNewTarget” to “Btsfindnewtarget” solved all issues with the AI in this regard…
This definitely needs to be looked into by Epic!

What do your logs say on editor startup when this happens. I am trying to see if this camelcase is causing others, and myself, blueprint readability issues in 4.5.1

Hey btengelh,

I wasn’t able to reproduce this issue. Does this happen in a new project as well, or are you only able to reproduce it in your project? If you can reproduce it in a new test project, could you put that online somewhere I can download it from, like Dropbox? Thanks!

Hi Ben,
thanks for your answer. I tried to reproduce it myself, but after changing it back to the camel case names it still works. It seems like it was a glitch, caused by the 4.4 to 4.5 migration… I’m sorry that I can’t give you a sample. If I ever stumble across this bug again, I’ll deep freeze the project and let you know.
Thanks & have a good time!

Hi,
This issue is back (4.7.6).
It is very similar to: https://answers.unrealengine.com/questions/122527/to-epic-blueprint-nodes-of-death-advanced-bp-bug.html and 2nd Time Blueprints get bugged by theirselfs - Blueprint - Unreal Engine Forums.

In my case it looks like this:

and:

These are the part of a BP code for a AI character. 1st is a event dispatcher made in custom game mode which is called using macro library function (pure casting) and 2nd one is a C++ function called from custom game instance also pure cast in macro library function.

Unfortunately I cannot provide any examples or code, since this is a commercial project with a lot of C++ code involved (blueprint I’m showing in screenshots has a C++ parent class), it would be to complicated to make it compile properly. We did migrate to new versions over the past months (from 4.5 initially, in which this blueprint was created) to current version). I did check if that’s the camelcase issue responsible for this, but some of the functions in blueprint are inherited from code, so I was able to change only few of them. It did help initially (after 1st restart), but it broke again (after the 2nd restart).

The problem with this issue is its randomness. It usually disconnects certain nodes each time I restart the editor, but there are the cases, that seem random, when they are ok. Then all I need is to restart again (not doing anything else) or to modify a different blueprint that is somehow related to this one (in example above other blueprint is calling bound event from the AI character blueprint after casting it to a proper object via custom game mode BP) and it breaks again.
Not sure if anyone investigated this issue more after last year’s reports, but I would be very grateful for any help with identifying the problem and fixing it.

Hi LanceK,

I attempted to reproduce the issue but so far I haven’t been able to. I understand that you can’t upload any parts of your game but could you try reproducing this in a new test project? It’s possible that the issue is either caused by custom code or only reproducible in a very specific scenario.

Hi TJ,
thank for quick response.
I’ll try to reproduce this when I get some spare time. Meanwhile I noticed one thing. In example above (broken_links_1), I have a macro "GetRuinerGameMode’ where output slot is labeled (when mouse over it) as “RuinerGamModeReference” and broken input slot in BindEvent is now called just “Reference” and an attempt to connect them ends with an error message saying they are not compatible (obviously). But then I create BindEvent by dragging a node from output slot of “GetRuinerGameMode”, the input of new node is called properly “RuinerGameModeReference” and all is fine and compatible. Which compatibility is the again broken after restarting the editor.

My programmer is away for another 2 weeks, but maybe you are able to determine, why this “reference” is being changed when running the blueprint verification code on editor start (or blueprint open, not sure when its being done), so this might be the overall cause of this issue? Could it be custom GameModes and GameInterfaces responsible?

Thanks and Kind Regards.
Lancek

I still haven’t been able to reproduce this behavior. I am going to mark this post as resolved for the time being. But when you get a test project created, just post back here and it will reopen the issue.

Cheers,

TJ

Hi TJ,

it seems that issue I was referring to is not present in 4.8 Preview 4. Not sure what actually fixed it, but as for now, the problem seems to be gone. So thanks :slight_smile:

Regards,

Lancek