Blueprint Lag

After editing my character blueprint for about a minute the entire blueprint begins to lag noticeably. My memory and cpu are at fine levels when this happens, but the blueprint editor is practically unusable when this happens, so I have to close and reopen my project. Is there a setting that I’m missing. Nothing I searched for online seems to address this issue specifically.

Thanks for the help.

Hey ,

Does this happen on every single blueprint that you edit? Including the blueprints that are within our normal templates provided by the Editor, or just your project’s blueprints specifically? Also, which version of the Editor are you working in?

Looking forward to hearing from you!

I’m using 4.7.6, I’m only getting the problem with this one project. Specifically in my character blueprint. When it happens every blueprint script in my project will lag until I exit the program, even if I close the character blueprint.

Hey ,

Is your character blueprint heavily used, or is it about the same if you were to compare them to the other character blueprints within our templates? Also, would you be able to submit any screenshots of your character blueprint, or even submit your project to me in a private message on the forums?

Thank you!

I’ll send you screenshots in a bit. Thanks. Edit: Sent

Hey ,

I’m looking over your blueprint you sent to me. This size of blueprint will definitely cause your blueprint editor to lag, especially if you don’t have a lot of memory within your computer. Would you mind sending me your dxidag ? You can locate them by using the search feature from your start bar on Windows. Simply press ‘save all information’ once you have dxdiag running.

Looking forward to hearing back from you! :slight_smile:

Here is my [dxdiag][1].
I don’t think it’s a memory issue, when the issue happens my ram is oftentimes sitting well below 80%.

40713-dxdiag.txt (67.5 KB)

Hey ,

Thanks for providing me with your dxdiag, you do have a lot of ram, and it’s well above what our minimum specifications are for UE4.

Would you mind migrating this blueprint over into a blank project so that I can look at it and see if it also lags on my system. If you do not mind sharing your project with me, you can always just zip that and upload it to me and provide me a link on the forums through a private message.

Also, do you notice any lag when you’re running the project that’s using the commands within these blueprints?


I’ll upload the whole project and send you a link when it’s uploaded. I don’t mind sharing the project as long as it doesn’t get distributed to anyone not involved with solving this issue. Thanks again for helping me resolve this issue.

Hey ,

Send me the link via the forums through a private message. No one will see the project, unless they’re trying to help me figure out why it’s lagging. It’ll also be deleted once we’re done with resolving the issue.

Feel free to update here once it’s sent to my inbox.

Thanks! :slight_smile:

Sorry it took me so long, just sent you the link.

Good morning,

I have downloaded your project and have opened your character blueprint. As I’m changing node connections within your blueprint, I do not notice any lag. Looking in my task manager, I see that Chrome is taking up more memory than the Editor. I’ve tried to get the blueprint to lag by minimizing and maximizing it multiple times too, as well as opening up other various blueprints within your project, and additional projects, so I have multiple Editors in the background running too. I use 32 GB of RAM on my machine, which could be why I’m not experiencing any lag.

When you’re working within the Editor, do you have any other programs open that would cause any type of system lag? Such as a 3D modeling program? Or even streaming music/videos on your web browser? Do you notice more lagging within your blueprint when it auto saves by any ?

It’s common that a blueprint of this size could cause some lag, depending on the memory available as well as your processing power of your CPU.


The issue comes into play when expanding the blueprint further, if I wanted to do a single line trace on tick and spawn an emitter the blueprint would be lagging by the time I specify what to do with the hit result.

The issue happens when I run UE4 in isolation as well as when I’m running it while using other applications, such as photoshop and Modo.

It’s not a memory issue, when in the blueprint editor my ram use isn’t even at 6 GB. The editor does lag with auto saves, but that’s different from this. The save lag is short, often less than 5 seconds, while the blueprint lag will last until I restart the project.

Hey ,

Have you tried collapsing your larger nodes, to see if there is a difference in performance with the blueprint editor? When you collapse them, there is a lot less seen, which makes it easier on your computer as well as the Editor.

Please let me know if that makes any type of difference. :slight_smile:

I collapsed most of the graph. It didn’t help, the issue still occurred. I do find that the issue often happens when returning to a maximized state after being minimized for a bit, but I would still like to point out that it’s not a memory or cpu issue because both of those levels are fine when it occurs. Also when the issue happens all blueprints in the project begin to lag too.

Is there some blueprint setting I can change to give the editor itself more power??

Hey ,

Have you tried changing the settings within the Pin Visibility within the View menu? You can select it to either Hide Unused Pins or Hide Unconnected Pins. That may help with a combination of collapsing some nodes.

Unfortunately, I can’t find any setting within the editor to give more power to it. However, within your Windows Task Manager, you can right-click on the Unreal Engine and set the priority, which may make it run more smoothly for you.

When you say that when the blueprint starts to lag, the project starts to lag too. Does that mean that the project lags while the blueprint is open, or it still lags once it’s been closed?


Hey ,

It’s been quite a while since I last heard from you. For tracking purposes, I must close this thread at this time. If you have any further questions regarding this topic, please do not hesitate to reply back to this thread. For any other questions, please post a new AnswerHub post.

Thanks! :slight_smile:


In UE4.13.1, we’re seeing this on several machines. The setups differ from older i5’s to newer i7’s. All setups have 16GB ram. They are all on Win7 64-bit. All working on SSD’s.

We haven’t experienced this issue previously and we’ve been on UE4 since years back.

Have you got any other ideas on what this problem could be?



I would suggestion submitting a new AnswerHub post with additional information, so we can better assist you.