Blueprint is not a 'object'

Hi! I’m creating blueprints through c++ and I’m succeeding to the point where I can see my functions in a blueprint, however when I try to call them I get the error “Blueprint is not a ‘object’”

How would I go about creating an object from my class?

Hi Netzone,

What did you mean when say “creating blueprints through c++”. Can you provide some example how to reproduce this error?

Best regards, Gleb

Header: // Fill out your copyright notice in the Description page of Project Settings. - Pastebin.com
cpp: // Fill out your copyright notice in the Description page of Project Settings. - Pastebin.com
BP: http://i.imgur.com/2X7AHGB.png
I’ve tried a bunch of stuff getting the blueprint working, like creating new class blueprints with GameServer, then casting to that (never goes beyond casting for some reason), or trying to get the GameServer object and then referencing that, but that never seems to work.

Basically it returns false when it shouldn’t, and the only reason I can think of is that it isn’t running at all.

I did a BP library too, but i’m always using a context object, like this:

UFUNCTION(BlueprintCallable, Category = Game, meta = (WorldContext = "WorldContextObject"))
	static bool SimpleTraceFromScreenToWorld(class UObject* WorldContextObject, const FVector2D ScreenPosition, /*out*/ FHitResult& HitResult);

and then interact with the engine from the context object.
Give it a try :wink:

I’m not sure what’s supposed to be different about that? I tried it and the blueprint output is exactly the same, something that seems extremely odd to me since there’s clearly another argument needed, but blueprint doesn’t seem to think so.

The result is also the same.

Did you try to make this function static?

Yup, no difference as far as I can tell.

I just want to synchronize our steps. I test your code and blueprint and I achieved similar error, because Connect to Server node require object to execute this member function (target socket in node). To avoid this you should make this function static. I wonder did you try to recreate this node? It looks like this node is very old.

In addition, look at this tutorial.

Hope it helps!
Gleb