Download

BluePrint In-App purchases IOS not working UE 4.7.5 Win

Hello,

I have an issue with In app Purchase on UE 4.7.5 for windows.

In-app purchase was working fine on UE 4.5.1 after a modification in the IOSEngine.ini (my last thread : here)

Since I have migrate to 4.7.5 the problem re-appear :

then I have added to the DefaultEngine.ini :


[OnlineSubsystem]
DefaultPlatformService=IOS

[OnlineSubsystemIOS.Store]
bSupportInAppPurchasing=True

But still the same…
here is the logs at UE Startup :


[2015.04.18-09.17.19:100]  0]LogModuleManager:Warning: ModuleManager: Unable to load module 'OnlineSubsystemIOS' because the file 'C:/Program Files/Unreal Engine/4.7/Engine/Binaries/Win64/' was not found.
[2015.04.18-09.17.19:100]  0]LogOnline:Warning: Unable to load default OnlineSubsystem module IOS, using NULL interface
[2015.04.18-09.17.19:127]  0]LogOnline:Verbose: NULL: Created thread (ID:3968).
...
...
...
[2015.04.18-09.18.55:475][175]LogOnline:Display: NULL: FOnlineSubsystemNull::Shutdown()
[2015.04.18-09.18.55:475][175]LogOnline:Display: Unloading online subsystem: Null
...
...


Is there a solution ?
Thanks for your help

Stéphane

Same problem here with Android/iOS.
Look my post: https://answers.unrealengine.com/questions/209822/android-and-ios-in-app-purchase-issue.html

Hi Helghast,
by your side, have you found a way to solve the problem ?

No. I hope that we should not touch code to fix it.
I think everything is properly configured in the project and GoogePlay but still returns “Failed”.

Maybe we should wait for the next update.

I have just installed the new upgrade : 4.7.6 but the issue persist… I did create a new blank BluePrint Project and launch it with no ini modification and it return :


[2015.04.21-14.10.00:902]  0]LogOnline:Warning: No default platform service specified for OnlineSubsystem

Hi all,

Terence Burns has been able to assist Helghast in this AnswerHub thread. Please have a look and see if it assists in your individual issues.

Thanks!

Hi wittlief,

I had a look at this Thread, thanks,
but In-app Purchase still not work for me on IOS (Not tested on Android), all seems to be well configured but all in-app functions return failed :


My defaultEngine.ini :

ini.JPG

I’m currently working on UE4.7.6 on a BluePrint Only project under Windows…
May be should I Install a github Version of UE and compile on a Mac with UnrealRemoteTool ? but I would prefer not…

:o Ok, Solved for IOS on UE 4.7.6 the good syntax is :


[OnlineSubsystemIOS.Store]
bSupportsInAppPurchasing=True


(it was not the same in the UE4.5.1 version…)

Thanks Helghast, wittlief, and thanks Terence !

Added this line but the error still persist in 4.14.2


LogModuleManager:Warning: No filename provided for module OnlineSubsystemIOS
LogModuleManager:Warning: ModuleManager: Unable to load module 'OnlineSubsystemIOS' because the file 'C:/Program Files (x86)/Epic Games/4.14/Engine/Binaries/Win64/' was not found.

did you solve it for Android? If you did, please show me the blueprint

Start a new thread dude, this one is four years old and is about UE 4.7. Get a totally fresh start on it.