Blueprint implementable event not being executed?

Hi, this is my first time posting, so I don’t know if I’m doing it in the right place.

Anyways, I’m making a LAN multiplayer game, learned about Blueprint implementable events and tried using them, but they are simply not working. So here is what I did.

I defined the event in my game instance class and then tried to call it.

UFUNCTION(BlueprintImplementableEvent, meta = (FriendlyName = "My Happy Event"))
void OnSessionFindCompleted();

GEngine->AddOnScreenDebugMessage(-1, 10.f, FColor::Red, "Before call");
GEngine->AddOnScreenDebugMessage(-1, 10.f, FColor::Red, "After call");

So this is what it looks like in game:

So the code is going through but the event is not being executed because it is supposed to hide the menu and some other stuff I set in blueprint:

I don’t know whats going on D: I hope I gave enough detail.
Please enlighten me!!

Did you check to see if the ‘Cast Failed’ branch of the cast node is being executed?

Hmmmm I haven’t but this sequence was working fine before I hooked it up with the event so I just assumed the event wasn’t executing. I’ll check it.

There is actually one more thing that can go wrong.
I see it using sessions, so it is online, the problem can be with client rights: clients not allowed to call events on server’s GameSession class even if they have instance as well as on GameMode, what is server only. You also can’t call event on other’s character if you are not authority.

Sorry for the late response and thank you very much for your responses. It looks like the cast was actually failing!! How could I’ve missed that!! Thanks a lot again!