Blueprint Game Mode not showing up

Hello, this may be a very basic question, but I’m new to Unreal and having a lot of trouble understanding the editor. One issue that came up is that I was investigating the side scrolling example project (not paper 2D one) and I opened the game mode to trying to figure out how it was constraining things to 2 axis. I clicked something and now my game mode blueprint and basic version is not showing up and I can’t figure out how to bring it back up. I’ve attached a screenshot with what I’m seeing.

Thanks in advance!

Hi and welcome to UE4!

Could you please create a blank project (no template) and manually create a game mode and then double click into it. Does it look OK?

1 Like

Check the Window Menu, be sure the “details panel” is selected. Had this problem before.


This pointed me to the right place. It was the “Class Defaults” window that I’d closed (I had no idea what one it was!) and for some reason I didn’t see this when I was looking before. Thanks Bariudol!

I faced a similar issue

when I somehow unclicked the “All Developers” radio button in the View Options submenu of the GameMode in the Blueprints menu. All of my GameModes were hidden.


While in the Game mode blueprint go to windows, and should see class defaults with a check mark beside it if not click it!

1 Like