Blueprint events crash packaged game

For some reason my packaged game keeps crashing with every event in myCharacter’s blueprint. Started off with the construction script, then the event begin play, and the event tick right after (Disconnecting the nodes and re-packaging every time). If I remove all of these, the game runs fine until I call any other event like an input action… Please help, I’m really starting to get frustrated about this : (

Here’s the log example of BeginPlay
[2015.01.08-05.30.30:229][ 0]LogOutputDevice:Warning:

Script Stack:

[2015.01.08-05.30.30:229][ 0]LogWindows:Error: Windows GetLastError: La operación se completó correctamente. (0)
[2015.01.08-05.30.30:313][ 0]LogWindows: === Critical error: ===
Assertion failed: Result [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.6\Engine\Source\Runtime\CoreUObject\Public\UObject\Stack.h] [Line: 224]

KERNELBASE.dll!UnknownFunction (0x00007ffa45068b9c) + 0 bytes [UnknownFile:0]

And here’s when I try Shooting:


Script Stack:

[2015.01.08-04.57.09:451][399]LogWindows:Error: Windows GetLastError: La operación se completó correctamente. (0)
[2015.01.08-04.57.09:535][399]LogWindows: === Critical error: ===
Assertion failed: Result [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.6\Engine\Source\Runtime\CoreUObject\Public\UObject\Stack.h] [Line: 224]

Hey -

Does the crash happen when playing in the editor in an a standalone game? Have you had the crash occur in a new blank project that you package? Does the crash happen when you attempt to move the character (this would call the “InputAxis MoveForward” or “InputAxis MoveRight” events)? If you could also include the log files from the crash it will help point to what is causing the crash. This should be created in the Saved->Logs folder where you packaged the game to.


When you have the chance, if you could send the log files from when the crash occurred it will help give an idea of what is causing it and how best to fix it.

Hey ! thanks for answering. Right now I dont have access to the engine, but I tried all these things you are talking about. Yes, the game crashes when I do a ‘Launch’ on the editor (playing in editor window works fine). The crash does NOT occur on other projects (new ones or my other little games). I can move the player perfectly fine, tho I did move these events to the player controller.

Log 1


Log 3

A couple other test questions came to mind recently. Do you get the same crash if you create a new character blueprint with an event? What is wired into the event node when the crash occurs (did you have the same thing wired into the construction script, begin play, and event tick and is so what was it?)

All I had on the construction event was setting up a few variables from the blueprint’s parent. (Health, movement speed, etc). I moved these variables into the begin play, re-packaged and crashed again. Went into testing the event again by removing these initial variables from the Begin Play, and once again, the game crashed. Then decided to remove the wires from the events, everything ran fine, until I pressed the unholster weapon/throw/item buttons that made my game crash every time I tested.

Now here’s an interesting thing I found: I made a copy of my character and left it just like it was. I added this character to the world settings and the game ran fine, 2 things differ from the original file tho: The animation blueprint doesn’t work on this copy because it uses the original for casting variables from myCharacter, myHUD (widget blueprint) also requires casting to myCharacter, therefore these 2 where not really working as they should in the package. Here’s where things start to get funny: I made a copy of the animation blueprint, created proper cast to myCharacter2, made it a package and it worked! Proceeded to correct the cast into myHUD’s blueprint, repackaged and BAM crashed. Removed myHUD’s cast and everything from the blueprint and now it crashes instantly, not working like last time. Did the same thing again but this time doing myHUD first and for my suprise the package worked… so I reconnected the animation and now it’s dead again.

I have no idea what’s going on…

So just to make sure I’m following what’s happening, when you associate either myHUD or the animation blueprint to myCharacter2 then it will work fine, but associating both of them to myCharacter2 does not? Is there anywhere where myHUD and the animation reference each other? Or some sort of circular reference (myCharacter calls myHUD but to preform the call myHUD has to make a call back to myCharacter)?

Could you test a new project with a simple animation and HUD cast to the character to see what the result is?

Yes, this is exactly what is happening. I’m pretty sure there’s no associating between these two, both communicate independently to myCharacter2. I will test this as soon as I get home and post results.

Do you guys want my project to analyze it? I really don’t know anymore what’s wrong…
A friend of mine is helping me building the engine from source to see what’s the problem, if we find something I’ll report back.

This is the best we could find:


Hey -

After some testing I am still unable to reproduce the crash. Are you packaging for windows or for another device (IOS, Andriod, etc.)? If possible, could you send a copy of your project where the crash is occurring for us to look it? If you have a dropbox to send it to you can then send me a private message on the forums with a link to the dropbox.

Thanks a lot for your help, , I will send this to you tomorrow afternoon!

Hey , I don’t know if you got the link as a private message in the forums. Just confirming that you did, I sent it on thursday, I think.

Hey -

Sorry for the delayed response. I did receive your project and have begun testing in it. The issue does seem to be with the CharacterGuns blueprint. Removing it completely or changing the default pawn to something else allows the packaged game to run without crashing. You may want to check any place that makes a call to the character (likely in the level blueprint or an “Event Begin Play” node since the crash is on launch). I have submitted a report of the crash to our internal tracking database (UE-7872) and will update you here when more information is available.