Blueprint editor pan

bug report / feature request

When you’re in the blueprint editor and you double click on a function, the view port will switch to the functions graph but the position will be wrong. It starts sliding towards where the nodes are. While it is sliding, if you zoom in or out, the view port will snap back to its initial (incorrect) position and zoom scale, then start sliding again. This is incredibly frustrating.

Please fix the position and zoom resetting when you scroll during the transition AND allow us to disable the smooth scroll completely, Thanks.

Hi ,

I’ve not been able to reproduce this on my end. Do you have a controller plugged in that may be moving your viewport?

Small vid showing the issue. I double click on a collapsed node (does the same thing for functions) and while its sliding i start scrolling up and down on the mouse, you can see the view jerks back to the starting position. - - YouTube

Hi ,

I was able to reproduce this and I have entered a bug report, UE-19469, to be assessed by the development staff. Having said that, I believe that the reason this occurs is because the camera is attempting to set to the middle of the function graph, and when zooming it resets the function attempting to set the camera. Allowing the camera to fully set should prevent this jerking motion from occurring.

Also made a small video Unreal Engine 4 Issue - Blueprint Graph Pan Animation causes great grief - YouTube

Please note that panning the camera with the mouse is also not possible until the animation has completed entirely, greatly impacting work speed.

Any news on this? an option to simply snap instead of panning would be nice.

There have been no updates to bug report: UE-19469. When this issue has been resolved, we will add and update to this post.