Blueprint creates new event tick on editor launch


I recently stumbled upon a problem I have never seen before. At some point, some of my blueprints started creating new events on their own, replacing some previous events. I believe it was after merging a git branch (we are using UE4 source control plugin for it) but I’m not sure.

For instance, I used to do something in the Tick event in a blueprint, but everytime I close the editor, when I open it again, a new event is here in place of the event tick, called ReceiveTick_1, and giving me a warning until I compile the blueprint. And of course this new event is not fired, it doesn’t seem to be a ticking event :


It also happens for BeginPlay and one other function, everytime naming it with a “_1” suffix.

Has anyone ever seen this problem and do you know of a way to solve it ? It’s really frustrating as I have to fix the blueprint everytime I launch the editor (committing and pushing the fixed version doesn’t change the problem and I’m not even sure Git is the cause of this problem).

Thanks in advance!

I’m still not sure what caused it but switching the project version to 4.19 solved it. So it was probably a bug in an earlier version.